Start New Discussion within our Hardware Community

I installed a new computer power supply. The new computer power supply starts then it stops all of a sudden. Can anyone help?

I installed the power supply. When I finally turned the computer on, the fans started to turn on, but all of a sudden they stopped. The green light went off on the power supply and I pulled the plug out of the PSU. When I plugged it back in, the green light came on again, and when I tried to turn it on, the fans turned on but suddenly stopped again. I checked all of the connections and everything is in the right place. I don't know what else to do...this has been mind-bloggling for 6 hours now. Please help...

Caperjack, I find it truly annoying that you need to known why lodaleader decided to install a new power supply in your second question, you should have asked that in your first one. You are not helping with his problem if you keep answering his questions with more questions. To refocus, his question simply was:

Why does a computer power supply shut off after two seconds?

Do you think you can answer that without playing 20 questions?

Comments
I find it more annoying that you post crap here as if you know how to help the OP
Thanks for joining just to bitch and moan without contributing anything of value.

Caperjack, I find it truly annoying that you need to known why lodaleader decided to install a new power supply in your second question, you should have asked that in your first one. You are not helping with his problem if you keep answering his questions with more questions. To refocus, his question simply was:

Why does a computer power supply shut off after two seconds?

Do you think you can answer that without playing 20 questions?

what ever , i find it annoying that you post a comment to a year old thread ,oh and i love 20 questions

This article has been dead for over six months. Start a new discussion instead.