0

Someone asked me to remedy a problem on a laptop running XP Media Center SP3...has a Seagate FreeAgent external hard drive, but Seagate Manager isn't recognizing the drive. When I plug the drive in, Windows recognizes and reads from the drive. I cannot uninstall the Seagate utility to reinstall it because it's not coming up in Add/Remove programs. Further, she told me that after this became an issue, she started using Windows Backup to back up her files, but that stopped working, too. From what I read so far, the NTBackup problem could be caused by a RSM database corruption - which would make sense as to why Seagate won't read the drive, but why does Windows read it? So, Windows reads it, Seagate won't recognize it, and NTBackup won't start.


Why I think it's a corrupt RSM database: I started Windows in Safe Mode and was able to get NTBackup running with no effort, but I got an error message that said Removable Storage Service is stopped, it will not run in Safe Mode. So I went and checked it in regular mode, and it was stopped, so I restarted it. It immediately stopped and said that It only runs when it has a job to do and won't stay started, even though the externam drive is plugged in (should this be running all the time anyway? Do writable drives count as removable storage?) I looked it up and found someone with a very similar problem, started it in Safe Mode, saw it wasn't running, couldn't start it, rebuilt the database and it worked fine. Does anyone with better knowledge of this problem know if I do this, will it fix my Seagate problem, too? Thanks!

1
Contributor
2
Replies
3
Views
7 Years
Discussion Span
Last Post by Tjmahone
0

Update: rebuilding the RSM worked for ntbackup, but still can't get seagate to recognize its own drive. How do I delete the software to reinstall it?

0

Was able to get a good installation of Seagate Manager in there...Deleting the old one was hard if not completely impossible because it did not show up in Add or Remove Programs. I essentially created a new folder and saved it there, then deleted the old folder and used CCleaner to delete the old registry values. I found out that the program wasn't recognized likely because Add/Remove Programs doesn't display programs with a registry value longer than 60 characters. Weird. Anyway, problem solved.

For anyone else who experiences the NTBackup problem and want to rebuild your RSM database, here is how to do it. First, use Computer Management to ensure the Removable Storage Service is stopped and won't start. Then, go to %systemroot%\System32\ntmsdata and copy the contents to another folder, then delete the contents in the ntms folder. Go back to services and start the removable storage service again, and Windows Backup should be fine.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.