0

I have a Dell Latitude D610 that will not power up with the ac adapter but will fire up with the battery, when I plug the ac adapter into the jack on the main board the green light on the ac adapter goes off which I've read means a short ether in the plug/jack on the main board or in the circuitry. I have swapped out 3 different ac adapters & all did the same thing, green light goes out as soon as you plug it into the jack on the computer. I also read this is a pretty common problem with some dells where the jack on the main board goes bad, so I bought a new jack for the main board & had it soldered in professionally, but am still having the same problem. any ideas what to try next?

2
Contributors
5
Replies
8
Views
7 Years
Discussion Span
Last Post by Rik_
0

Looks like you will have to get it professionally diagnosed. I have 6 Dell d610's in the workshop at the moment. All have the exact same problem as yours. If I get a chance to figure the fault on one of them I will let you know. Don't hold your breath though, I have a lot of other laptops to repair so the Dells are way down on the list.

Edited by Rik_: n/a

0

thanks Rik. whenever you get the chance. any help would be greatly appreciated.

0

The problem is I have so many other laptops to repair and I get more in on a daily basis, 7 days a week. Those Dells belong to us, not customers, so it is likely to be several months before I will have a chance to look at them.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.