0

Help you Techies please .I have owned a Dell Inspiron 2500 for 4years and now it has just decided not to start....
1 > mains attached(new tested mains supply)/battery installed (new battery) no lights on.
2 > no battery and mains attached ,no lights.....
HO HUM ....what now...
I have dissembled the machine down to nealy all components and reassemled hoping it was a connection problem but NO RESULT.
Help Please ..........

6
Contributors
8
Replies
10
Views
11 Years
Discussion Span
Last Post by laladybug
1

Well, if you're sure that it's plugged in :cheesy:, and you're sure that it isn't the power supply that isn't crapping out, why don't you try some of the following:

1. It could be the on/off switch. Try using a different motherboard (If you have one).
2. It could also be the motherboard at fault. Maybe a circuit is fried or something. You can test this also, if you have another computer with a working motherboard.
3. If all else fails, the BIOS may be dead. This is a little harder to swap, but if the BIOS is dead, it's highly likely that the computer won't boot.

Have fun ;)

0

many thanks but spare bits are not readily available to me....but i will investigate.....any other info will be appreciated

1

many thanks but spare bits are not readily available to me....but i will investigate.....any other info will be appreciated

some time after a lot of use the connection between the power plug and the motherboard can brake away from the board of the laptop and need to resoldered,try to wiggle the cord at the laptop connection when turning it on,
as said above the board or even the cpu could be dead.i had simular Dell one with a dead battery and it would not start without the battery connected ,bought new battery and it worked great

0

Thanks ,I will try all suggestions ....A new battery was fitted recently and was working well before the demise of life !!!! must be something simple because its always the silly thing which confuses my brain ........ any more suggestions appreciated

0

Did you try Dell Tech Support? Pretty sure they ought to be able to help you.

Otherwise, try removing the RAM sticks and then try powering the system. Does it beep at all? Also, when you switch on the system, do the fans rotate?

0

The fans and lights are not working ....it is dead.deceased,a non laptop !! all i have is a light on the power transformer.....
I have tried with or without the battery and mem sticks ..nowt !! thanks goldeagle any more suggestions ...

0

Did you try Dell Tech Support? Pretty sure they ought to be able to help you.

Otherwise, try removing the RAM sticks and then try powering the system. Does it beep at all? Also, when you switch on the system, do the fans rotate?

I have a similar problem but my fan and lights are working. The fan turns on for a few seconds and then nothing. There is still power to the cd drawer but it just wont boot. Have tried starting with the xp cd in the drive and also I replaced the hard drive but nothing.
Any ideas would be fantastic.

0

It is most likely the charging port has broken away from the motherboard,it can be soldered back together if this is the case...hope this helps!

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.