0

Hi all...

I sure hope someone can help here!! I have the Inspiron 1150, just over a year old and in November had the motherboard replaced because the power supply connection just broke off. Warranty out in Jan, now there is just a black screen when the computer turns on. I can BARELY see the windows logo and all, it is booting up but you can't see the screen. On first start up, the Dell logo with blue flashes bright, then it just goes dark. I've tried doing the FN /crt key thing (saw it on an earlier post)but nothing. Any suggestions? Thanks much in advance, I cannot afford another laptop!!!

5
Contributors
6
Replies
7
Views
11 Years
Discussion Span
Last Post by ukbajan
-1

Perhaps you need to increase the screen brightness (on my Dell Latitude D510 the hotkey is Fn+Up Arrow).
Just a suggestion, but it might just work.

Hope that helps,

0

That's... bad.


Probably worse than dead pixels. I hope this doesn't involve the hard drive, or Windows, as it would make many new problems and much harder to fix. Nonetheless, a screen that darkens and flashes is not healthy nor is it common.

I couldn't tell you what to do with this.

0

thanks...the screen brightening didn't work, from what I've seen in other threads about this particular model, this is pretty common, to the point where people have talked about a class action so I guess there's not much of a fix:(:( Brand new motherboard too!!

0

Hi all...

I sure hope someone can help here!! I have the Inspiron 1150, just over a year old and in November had the motherboard replaced because the power supply connection just broke off. Warranty out in Jan, now there is just a black screen when the computer turns on. I can BARELY see the windows logo and all, it is booting up but you can't see the screen. On first start up, the Dell logo with blue flashes bright, then it just goes dark. I've tried doing the FN /crt key thing (saw it on an earlier post)but nothing. Any suggestions? Thanks much in advance, I cannot afford another laptop!!!

i have got the same problem and as far as i can see it is the inverter that has gone wrong. it's a simple case of replacing it

0

Did you find out what was wrong with your 1150? Mine is doing the same thing & I hate the fact that I've got a glorified paper weight!

0

it is the inverter that has gone wrong. i would suggest that you pay a visit to ebay which seems to be the cheapest place to get a replacement.

please bear in mind that there are 2 varieties of inverter available for this model. one is for the 14" screen, the other is for the 15" screen. please get the correct one or you have wasted your money.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.