0

I'm trying to mount my SD card to my computer because the auto mount feature isn't working for some reason.
The card shows up on the first line of the 'lsusb' command, I know that's it because that line goes away
when I take the card out and re-run the command, so I know my system can see the device. Also, it should
be /dev/sdd because /dev/sdd also goes away if I take the card out and only appears when I run 'ls /dev'
and the SD card is plugged in. But there's only one FAT32 devie that appears when I run 'sudo blkid' and
that shows up as /dev/sdb2, and when I mount it and then look into that mounted directory it isn't the
contents of my SD card. Any ideas?

garrett@bedroom ~ $ ls /dev
alarm          char             full     loop0         mcelog              ppp    ram14  random  sdb2  sg1       stdout  tty16  tty25  tty34  tty43  tty52  tty61      ttyS11  ttyS20  ttyS3   urandom     vcs5   vcsa6
ashmem         console          fuse     loop1         mem                 psaux  ram15  rfkill  sdb3  sg2       tty     tty17  tty26  tty35  tty44  tty53  tty62      ttyS12  ttyS21  ttyS30  v4l         vcs6   vcsa7
autofs         core             hidraw0  loop2         net                 ptmx   ram2   rtc     sdb4  sg3       tty0    tty18  tty27  tty36  tty45  tty54  tty63      ttyS13  ttyS22  ttyS31  vboxdrv     vcs7   vcsa8
binder         cpu              hidraw1  loop3         network_latency     pts    ram3   rtc0    sdb5  sg4       tty1    tty19  tty28  tty37  tty46  tty55  tty7       ttyS14  ttyS23  ttyS4   vboxnetctl  vcs8   vga_arbiter
block          cpu_dma_latency  hidraw2  loop4         network_throughput  ram0   ram4   sda     sdb6  shm       tty10   tty2   tty29  tty38  tty47  tty56  tty8       ttyS15  ttyS24  ttyS5   vboxusb     vcsa   vhost-net
bsg            disk             hpet     loop5         null                ram1   ram5   sda1    sdb7  snapshot  tty11   tty20  tty3   tty39  tty48  tty57  tty9       ttyS16  ttyS25  ttyS6   vcs         vcsa1  video0
btrfs-control  dvd              input    loop6         nvidia0             ram10  ram6   sda2    sdb8  snd       tty12   tty21  tty30  tty4   tty49  tty58  ttyprintk  ttyS17  ttyS26  ttyS7   vcs1        vcsa2  zero
bus            dvdrw            kmsg     loop7         nvidiactl           ram11  ram7   sda5    sdc   sr0       tty13   tty22  tty31  tty40  tty5   tty59  ttyS0      ttyS18  ttyS27  ttyS8   vcs2        vcsa3
cdrom          ecryptfs         kvm      loop-control  oldmem              ram12  ram8   sdb     sdd   stderr    tty14   tty23  tty32  tty41  tty50  tty6   ttyS1      ttyS19  ttyS28  ttyS9   vcs3        vcsa4
cdrw           fd               log      mapper        port                ram13  ram9   sdb1    sg0   stdin     tty15   tty24  tty33  tty42  tty51  tty60  ttyS10     ttyS2   ttyS29  uinput  vcs4        vcsa5

garrett@bedroom ~ $ lsusb
Bus 001 Device 006: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
Bus 003 Device 002: ID 0557:8021 ATEN International Co., Ltd 
Bus 005 Device 002: ID 045e:076d Microsoft Corp. LifeCam HD-5000
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 0461:4d64 Primax Electronics, Ltd 
Bus 003 Device 004: ID 0557:2212 ATEN International Co., Ltd 

garrett@bedroom ~ $ sudo blkid
/dev/sda1: UUID="5bdbdd40-1d20-4212-bd5e-ea59265358aa" TYPE="ext4" 
/dev/sda5: UUID="ca1a15c9-46be-4d2a-ac3b-2f34a5d403f0" TYPE="swap" 
/dev/sdb1: LABEL="Windows RE tools" UUID="9EDC4B0EDC4AE05F" TYPE="ntfs" 
/dev/sdb2: LABEL="SYSTEM" UUID="CC4D-6838" TYPE="vfat" 
/dev/sdb4: LABEL="Windows" UUID="008ECADA8ECAC77E" TYPE="ntfs" 
/dev/sdb5: UUID="46EE226CEE225509" TYPE="ntfs" 
/dev/sdb6: LABEL="Data" UUID="703ACC8D3ACC5230" TYPE="ntfs" 
/dev/sdb7: LABEL="Files" UUID="d6c45990-4eeb-4cc4-9e96-554015cca820" TYPE="ext4" 
/dev/sdb8: LABEL="New Volume" UUID="58DAF426DAF3FDD6" TYPE="ntfs" 
/dev/sdc: UUID="86e3838b-7c18-4870-8a7b-684255629264" TYPE="ext4" 

garrett@bedroom ~ $ sudo mount -t vfat /dev/sdd1 /media/garrett/mnt/
mount: special device /dev/sdd1 does not exist

garrett@bedroom ~ $ sudo mount -t vfat /dev/sdd /media/garrett/mnt/
mount: no medium found on /dev/sdd

Edited by happygeek: moved

2
Contributors
2
Replies
10
Views
3 Years
Discussion Span
Last Post by happygeek
This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.