0

I was formatting my phones micro SD using an adapter in my Asus's SD slot.

After formatting and retrieving the card, the phone said the format wasn't right so I plugged it back in my computer. But the computer no longer listed inserted SD cards. I tried a couple other SD cards from cameras to no avail.

However, on the bottom right corner an icon does appear telling me "Safely Remove Hardware and Eject Media / SD Card".

Tried downloading the driver from Asus but nothing changed. Then tried system restore a couple of times to different restore points but both times the restore couldn't be completed.

Any ideas?

Thank you!

3
Contributors
3
Replies
10
Views
3 Years
Discussion Span
Last Post by Xlphos
0

If you remove an SD card (or USB thumb drive, or other device) from your computer without doing the "safely remove" thing, you are likely to lose EVERYTHING on the device. The OS caches device writes, so until you select "safely remove", or on Linux "unmount/eject", the device will be seriously compromised. In your case, you will probably need to reformat the devices and backup the data again, and THEN select "safely remove" or "eject". If that device had the source data, then you will be into serious data recovery efforts. Not simple, but possible - maybe... :-(

0

I know that and it is not a concern since I had just formatted that micro SD so there was no data already.

My question is, why is the computer no longer giving me the letter drive when I put an SD card inside.

0

hello, if you search for partition and select create and format partitions of the sd card show in the disk manager?

you should be able to format it from there if you cant see it under 'computer'

you should also be able to give it a drive letter if it does not have one.

  • let us know how it goes

Edited by Xlphos

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.