Hi,

So I have a system with the ryzen 2700x
the motherboard is the Aorus b450 pro.
in terms of power I have a Seasonic Focus GX-850

Now the problem. basically I render a lot on my PC so it is often on. Woke up this morning, my PC had lights on on the Motherboard around the logo's of Aorus.
But it didn't start. Now I switch the button on the back of the PSU. And then start it again. It shows a second of light if even that.
And then Nothing...

what have I tried:

I tried putting the power straight in the wall, made no difference.
I have tried a different cable to the PSU no difference.
Tried making sure that for some reason the jumper cable didn't come lose. (not it either)
I had 1 intresting result. I replaced 3v battery on the motherboard, This resulted in my PC starting. till JUST before windows booted,
And then... It went back to the beginning of the lights on the logo's of the Motherboard,
But I couldn't start it, and of course it is back at the start with what it does now.

Any clue what could be wrong here? The PSU I bought in may 2020... So it is a reasonbly new one.

Hope you guys happen to know what is going on.

This issue is usually tackled with the "make it smaller" approach. I don't see the rest of the PC mentioned which could have me comment about what cards I'm seeing fail now such as graphic cards of the time of GTX 970 and earlier.

There's also the too often find where there is an extra mounting stud that has finally worn through some PCB paint and creating issues. Your story doesn't lead me to what it can be so we are left to meander a little but focus on "make it as small as possible." This can lead us to building the PC on cardboard to see what few parts we can build with that work right. We don't need a case and what else?

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.