0

i have a problem with my computer not starting up.
at first it would not do anything so i replaced the psu with a new one of same type. now i get constant blinking lights on switch and hdd led's on the front panel. the hdd was making a clicking noise so i unplugged the ribbon cable and put it back , now the click is gone but i still have blinking led's. nothing else.
the psu fan is running.
the cooling fan on cpu tries to start but just hesitates , wont run.
pushing the power switch on front panel will not change a thing.
i have unplugged all cables and put back but no change.
i have cleaned a lot of dust from mobo and cpu cooler but no change.
thanks for any help !

1
Contributor
1
Reply
2
Views
11 Years
Discussion Span
Last Post by jebuch
0

i have a problem with my computer not starting up.
at first it would not do anything so i replaced the psu with a new one of same type. now i get constant blinking lights on switch and hdd led's on the front panel. the hdd was making a clicking noise so i unplugged the ribbon cable and put it back , now the click is gone but i still have blinking led's. nothing else.
the psu fan is running.
the cooling fan on cpu tries to start but just hesitates , wont run.
pushing the power switch on front panel will not change a thing.
i have unplugged all cables and put back but no change.
i have cleaned a lot of dust from mobo and cpu cooler but no change.
thanks for any help !

i just unhooked the 4 pin wire from the psu to the mobo and the cpu cooling fan started to run but still i have those blinking power switch and hdd lights .
would i have to have monitor and keyboard hooked up to stop all that blinking.
also the push buton power switch will not shut down the computer. it just keps on blinking and blinking and blinking. very fast!
no noise coming from hd. thanks

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.