When I start up my computer it says my memory frequency is set to 166 mhz, and unless i am wrong then its talking about my ram speed. The main issue is that I have 2 ram sticks and both are 333mhz. How would i set it up so its runs at 333Mhz??

What I Use-
Processor: Athlon 2800+XP
Motherboard: Asus A7N8X-X
Graphics card: Gforce FX5200
and 2 sticks of 512 PC2700

This problem isnt recent I have had this happen to me for quite some time. I tried taking out ram sticks and stuff like that to see if that would have any effect.
BTW- In bios it wont let me choose a specific speed for it. Just gives me Auto and byspd

14 Years
Discussion Span
Last Post by Skull-Drizzt

Usually, unless you overclock, you'll want to go with SPD setting in BIOS for your RAM. I use Abit boards though which gives me the option of having preset tweaks that I can switch to. Perhaps your BIOS might have the same...but it is safe to set timing by SPD which is "Serial Presence Detect" (pretty much fancy for automatically set by BIOS and CPU) :)


Yes. But there's another reason than overclocking to alter the BIOS settings for RAM.

If the RAM modules were, say, PC3200 400MHz ones, then the best procedure to follow would be to set things up to be identified automatically as you've suggented, to have RAM timings operating in accordance with the manufacturer's specifications. But then you'd be best to go back and change the RAM SPEED so that it was actually running at 333MHz, rather than the 400MHz it's capable of.

Sound silly? It's not. The system works best when the RAM is running 'in sync' with the processor's bus speed. Run your RAM at a faster speed than the front side bus of the processor, and your CPU will sit there confused a fair bit of the time, like a kid who's trying to get the timing right to jump onto the playground roundabout! The end result will be that your overall system will be slowed down by the faster RAM, not speeded up.

The speed you should have your RAM running at is the speed of your processor's front side bus, and if you need to change the settings to 'Manual' to do so, then you should.


Hence SPD...which times RAM and FSB automatically together without conflicts.


It's already doing 333MHz. It's Dual Data Rate memory.

Times that 166 by 2 and see what you get ;)

lol omg >< doh didnt know that. Thx for clearing that up for me.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.