0

My apologies for the length but am unsure of specific diagnostic data needed for trouble shooting responses. From perusing the threads, there are a lot of competent people who are really sharp in these matters. If additional info/diagnostics are needed, let me know. I've researched a lot of Liteon/Microsoft/Intel et al web sites but haven't found the resolution, as yet.

I've posted the following on other boards with one response that has provided some assistance but am still plagued and mystified by the problem. The following was my original post. Current status follows the initial post.

:sad: PROBLEM:
Disappearing Drives
(sometimes hours after startup; sometimes minutes after; Reboot resets drives; Reads previously burned CD-RW info OK):

Internal: LITE-ON LTR-24102B Firmware:5S54 Driver:cdrom.sys (5.1.2600.1106 (xpsp1.020828-1920)

Internal: LITEON_DVD-ROM_LTD163 Firmware:GH5E
Driver: cdrom.sys (5.1.2600.1106 (xpsp1.020828-1920)
(Afraid to flash updated firmware until issue(s) are resolved)

When Intel Application Accelerator is installed, Event Viewer shows Idechndr is not responding within timeout and the error cycles every 5 seconds slowing system response until it shows both the devices (CD-RW and DVD) disappearing from system.

Tried using Intel Accelerator to slow the drive speeds down to PIO (per Intel guidance) w/o success. Intel Accelerator initially shows the CD-RW as Master on Secondary IDE Channel and DVD as Slave. Hard Drive is shown as Master on Primary and Empty on Primary Slave until devices disappear.

Uninstalled Intel Accelerator and now the event viewer shows error of Device\Ide\IdePort1 and then IdePort0 failing to respond within timeout and they disappear from system.

Have disabled Imapi but have noticed that Event Viewer shows sending a start Imapi CD-Burning COM signal, then it show Imapi starting then stopping just before each Error of either Idechndr or atapi Error starting up

For a baseline SYSTEM INFORMATION overview:
System Summary
OS Name Microsoft Windows XP Home Edition
Version 5.1.2600 Service Pack 1 Build 2600
OS Manufacturer Microsoft Corporation
System Name VIPER
System Manufacturer vpr Matrix
System Model 1600
System Type X86-based PC
Processor x86 Family 15 Model 1 Stepping 2 GenuineIntel ~1594 Mhz
BIOS Version/Date Intel Corp. PT84510A.86A.0030.P08.0301300054, 1/30/2003
SMBIOS Version 2.3
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\System32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = "5.1.2600.1106 (xpsp1.020828-1920)"
Total Physical Memory 512.00 MB
Available Physical Memory 250.79 MB
Total Virtual Memory 1.72 GB
Available Virtual Memory 1.26 GB
Page File Space 1.22 GB
Page File C:\pagefile.sys

CONFLICTS/SHARING
I/O Port 0x00000000-0x00000CF7 PCI bus
I/O Port 0x00000000-0x00000CF7 Direct memory access controller

I/O Port 0x000003C0-0x000003DF Intel(R) 82845 Processor to AGP Controller - 1A31
I/O Port 0x000003C0-0x000003DF NVIDIA RIVA TNT2 Model 64 Pro

IRQ 23 U.S. Robotics 56K Voice Host Int
IRQ 23 Intel(r) 82801BA/BAM USB Universal Host Controller - 2444

IRQ 9 Microsoft ACPI-Compliant System
IRQ 9 Intel(R) 82801BA/BAM SMBus Controller - 2443

IRQ 17 Texas Instruments OHCI Compliant IEEE 1394 Host Controller
IRQ 17 SoundMAX Integrated Digital Audio

Memory Address 0xA0000-0xBFFFF Intel(R) 82845 Processor to AGP Controller - 1A31
Memory Address 0xA0000-0xBFFFF NVIDIA RIVA TNT2 Model 64 Pro


I/O Port 0x000003B0-0x000003BB Intel(R) 82845 Processor to AGP Controller - 1A31
I/O Port 0x000003B0-0x000003BB NVIDIA RIVA TNT2 Model 64 Pro


DMA
Channel 2 Standard floppy disk controller OK
Channel 4 Direct memory access controller OK

COMPONENTS - CD-ROM
Drive D:
Description CD-ROM Drive
Media Loaded No
Media Type CD-ROM
Name LITE-ON LTR-24102B
Manufacturer (Standard CD-ROM drives)
Status OK
Transfer Rate Not Available
SCSI Target ID 0
PNP Device ID IDE\CDROMLITE-ON_LTR-24102B 5S54_ \5&29F63E6A&0&0.0.0
Driver c:\windows\system32\drivers\cdrom.sys (5.1.2600.1106 (xpsp1.020828-1920), 46.38 KB (47,488 bytes), 8/17/2001 12:52 PM)

Drive E:
Description CD-ROM Drive
Media Loaded No
Media Type CD-ROM
Name LITEON DVD-ROM LTD163
Manufacturer (Standard CD-ROM drives)
Status OK
Transfer Rate Not Available
SCSI Target ID 1
PNP Device ID IDE\CDROMLITEON_DVD-ROM_LTD163_ GH5E____\5&29F63E6A&0&0.1.0
Driver c:\windows\system32\drivers\cdrom.sys (5.1.2600.1106 (xpsp1.020828-1920), 46.38 KB (47,488 bytes), 8/17/2001 12:52 PM)

COMPONENTS-STORAGE-IDE
Name Intel(r) 82801BA Bus Master IDE Controller
Manufacturer Intel
Status OK
PNP Device ID PCI\VEN_8086&DEV_244B&SUBSYS_50548086&REV_05\3&61AAA01&0&F9
I/O Port 0x0000FFA0-0x0000FFAF
Driver c:\windows\system32\drivers\intelide.sys (5.1.2600.1106 (xpsp1.020828-1920), 4.63 KB (4,736 bytes), 8/17/2001 12:51 PM)

Name Primary IDE Channel
Manufacturer (Standard IDE ATA/ATAPI controllers)
Status OK
PNP Device ID PCIIDE\IDECHANNEL\4&F906996&0&0
I/O Port 0x000001F0-0x000001F7
I/O Port 0x000003F6-0x000003F6
IRQ Channel IRQ 14
Driver c:\windows\system32\drivers\atapi.sys (5.1.2600.1106 (xpsp1.020828-1920), 84.88 KB (86,912 bytes), 8/17/2001 12:51 PM)

Name Secondary IDE Channel
Manufacturer (Standard IDE ATA/ATAPI controllers)
Status OK
PNP Device ID PCIIDE\IDECHANNEL\4&F906996&0&1
I/O Port 0x00000170-0x00000177
I/O Port 0x00000376-0x00000376
IRQ Channel IRQ 15
Driver c:\windows\system32\drivers\atapi.sys (5.1.2600.1106 (xpsp1.020828-1920), 84.88 KB (86,912 bytes), 8/17/2001 12:51 PM)

The above was posted on dvdrbase.com and the thread's administrator offered it may be an Intel Mobo/chip/Intel Application Accelerator issue (seems there are Intel issues with similar problems) Unfortunately, resetting the bus to a standard Dual Channel PCI IDE Controller and standard windows drivers only changed the Errors and the drives continue to 'disappear'. :sad: :evil: At least I was able to flash and upgrade the drives' firmware to their current versions but the issues continue. For his responses and my current circumstance/pending next steps, see: http://www.dvdrbase.com/showthread.php?t=36131

Any assistance and/or insight into possible causes/solutions the members of this board might offer would be greatly appreciated.

Telecorder

2
Contributors
5
Replies
6
Views
13 Years
Discussion Span
Last Post by Telecorder
0

liteon ranks right up there with CD-RW's i don't like ,have you tried another CDRW

Not as yet. As in everything, when somethings has always worked without any problems, you usually like it; If you have problems and get frustrated, you dislike or hate it.

Having said that, its on my agenda to disconnect, in order, the CD-RW and then the DVD drives to see if the issue(s) continue. While possible, I believe its improbable that both drives would become defective at the same time. Currently, I'm leaning to an Intel issue as the possible culprit.

In doing searches on the web, I came across the following in an Intel specification paper that, IMHO, may be the unresolved culprit:
Intel 82801BA

I/O Controller Hub 2 (ICH2)

and Intel 82801BAM

I/O Controller Hub 2 Mobile (ICH2-M)

Specification Update

January 2004

41. Delayed Transaction Timeout Bit Issue

Problem: After a delayed transaction has been serviced the discard timer is not reset, which incorrectly times out. This timeout sets the SERR# Due to Delayed Transaction Timeout bit (D30:F0;92h:bit-1).

This may result in generation of SERR# based NMIs if the SERR# enable on Delayed Transaction

Timeout bit (D30:F0;90h:bit-1) is set to a 1 by software or system BIOS.

Implication: This erratum may cause excessive NMIs to occur which impacts system performance.

Workaround: System BIOS must clear D30:F0;90h:bit-1 to 0 if the delayed transaction based SERR#s should

not be generated on the platform.

Status: This will not be fixed in the ICH2/ICH2-M.:cry:


While I'm far from being PC literate, the above issue would seem to fit the bill if the IDE drives are being timed out due to a failure of the bus to reset the timeout bit. But, I may be way off base...:rolleyes:

At any rate, I infrequently use either drives, usually only to burn a CD-R or CD-RW for files and information to leave with clients. I've disabled both drives for the time being until I get motivated to attack the spaghetti of cables behind my furniture and dig into the PC case to disconnect the drives.

If, and when, it turns out to actually be the drive(s), I'll consider picking up another CD-RW and/or DVD drive. Until then, I'll keep posting on the boards hoping that someone will have identified the issue(s) and detail the causes/resolutions/work arounds.

Thanks for taking the time to reply.:)

Telecorder

0

Both Drives ,Missed that when i first read post sorry,Have you tried reinstall motherboard drivers ,Any yellow ! marks in device manager pertaining to the IDE devices ,
I to am far from being PC Literate just throwing out possibility.

0

Both Drives ,Missed that when i first read post sorry,Have you tried reinstall motherboard drivers ,Any yellow ! marks in device manager pertaining to the IDE devices ,
I to am far from being PC Literate just throwing out possibility.

I installed upgrade Intel drivers for the BIOS, Mobo and chipset; installed updated Firmware for both the optical drives and latest IAA thinking that, perhaps, one or more would addresss the issue. Unfortunately, none worked. Likewise, again unfortunately, I'm not really sure of when the issue started so I could go back and determine if it is a software-induced issue or a hardware issue that popped up.:cry:

I recognize that an eventual and potential solution is to do a clean reinstall of WIN XP to eliminate a possible corrupt SYS file or hidden driver but, geez, too many recurring incidents of 'disappearing optical drives' without any reports of the OS being identified as being the issue would seem to point to it being a hardware issue.

Device Manager does not indicate any problems with any device in the system or any conflicts present, even when the Event Viewer is reporting the continuing "failure to respond within timeout" every five seconds. During these events, the system is definitely slowed. Attempting to disable the optical drives during this cycling usually results in the Device Manager hanging and 'failing to respond'.

Interestingly enough, when the drives have 'disappeared' from the system, they are still detected when running BELARC Advisor (which, in my mind, begs the question, if BELARC can query the device and determine its info after they 'disappear', why is the system having issues with getting the device to respond within a timeout period?)

This would seem to indicate that the cable connections are still good/functional, the devices are still able to communicate and are 'somewhat functional' and that, just maybe, its a communication problem in the system bus controller...

Based on the ICH2 issue that Intel posted (see my previous post), I've tried to send a message to Intel to see if this could be the issue creating the problems. Of course, their support wizard screens out the unsupported equipment support requests and won't allow you to send the request saying just read our web-posted information for your solution...:sad: :evil: I guess that I (and others) are relegated to boards and forums such as this one for determining the conflicts and possible work arounds/solutions.

And the sad saga continues, begging for insight and directions...:sad:


Telecorder

0

I physically swapped the drives in the PC case to facilitate installing the CD-RW at the end of the 40-pin/80-conductor cable as the jumpered Master and the DVD-ROM at mid-cable as jumpered Slave. 72+ hours without any timeout errors and counting.:cheesy: :) :cool:

Many thanks to all who responded and offered insight & assistance.


Telecorder

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.