0

i'm not sure if this item has ever been adressed but, i can't get the disk drive on my g4 to open....i press the button(top right corner of keyboard) and no response....i tried rebooting and still no results. Any suggestions on how to solve this even if just temporarily are greatly appreciated.

thanx

6
Contributors
11
Replies
12
Views
13 Years
Discussion Span
Last Post by chels126
0

Top right corner of the keyboard... That's the reset button on many many Mac keyboards. I assume you're pressing the "eject" button, and apple changed the key layout on someone who's about 7 years behind current mac technology.

Sometimes you have to press and hold a button such as that, or try pushing the drive back in.

0

well yes i am pushing the eject button and the disk drive has like no power at all.....i can get it to open by manually opening it by pushing the manual eject button on the inside of the drive itself and then i have to pull the tray it self out but this is where it gets out of the ordinary.....as you know once the drive is open you can put a cd into the tray and give the tray a little nudge and the comp sucks it right back in....well mine doesnt respond at all its like no power is getting to the disk drive cuz one i push the tray in it doesnt even attempt to read what i put in, my computer has been having this problem on and off for about a week now, sometimes it will randomly work for like a couple minutes and ill be all excited, then later on when i want to get the disk out or put a new one in it regains its retardation..........someone help any advice at this point is good advice

0

update the drive does have power and does read cds games etc., but the tray wont open or close or respond at all to the keyboard eject key

0

Perhaps you should try a different power connector.

Did the eject button ever work? My Windows experience tells me you may need a driver to use it, or to enable the feature.

0

yea it worked the whole time since i got it up until like 2-3 weeks ago..... i took it to this place called "comp USA" and the lead tech went at the thing with a friggin penknife(no results of course)

0

Definintely check the power connectors on the drive. Does the unit even show any lights, or does it read discs?

Also, if you're running OS 9.1 or below, and you have a CD in the drive, highlight the icon of the device in the Finder, and hit Command-Y. That would eject the drive there; I've forgotten how to do it in OS X.

0

how do i make a link out of a command on my computer....i.e- c:/
i really need to know how to do this to send a link to my friend that is out of the "run" system on the start menu on mine as well as his computer. If you have any advice that you can give me on how to make a hyperlink out of a c:/ please respond promptly

0

How do i make a hyperlink out of a c:/ command

No idea - ask on a Windows forum :)

0

i am having a problem opening my disk drive on my dell dimention desktop computer...when i push the button nothing happens and it doesnt open or show the activity light on..any suggestions??

thanx-

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.