0

Hows it going guys, I'm having a few troubles with several hard drives, so grab a glass of milk and some cookies because your going to be sitting here a while.

Okay. So to start the story, I was using three seperate hard drives as follows:

IDE 0 - 40 Gig - Master
IDE 0 - 80 Gig - Slave
-------------------------
IDE 1 - 15 Gig - Slave
IDE 1 - (CD-RW Drive)

Not only is it a hassle to juggle files between multiple hard drives, but the 127 gigabytes or so of space was not nearly sufficient enough for me. In fact I am using an old laptop and an old dell to store other files of mine that wouldn't fit on these drives.

So the solution was obviously to buy a new hard drive and this is what I did. I bought a 500 gig hard drive from western digital, and it being newer it is SATA. My MSI motherboard has 2 SATA slots, so I hooked it up, but at first it was not being recognized.

So - I took all the IDE hard drives out, and put the SATA in by itself. Still no luck. I then went into BIOS and after some trial and error managed to get it to recognize the SATA hard drive.

I then put the 80 gig IDE hard drive in and the 40 gig IDE hard drive in, the computer booted up fine, but this time the SATA hard drive is no longer recognized. I know it has power, I can feel and hear it spinning... so basically why is it no longer being recognized? Does it have something to do with the jumper slot for master/slave???

I know that by default SATA is suppose to be master over any IDE drives (right?) but I want the 40 gig IDE to stay master since that has my copy of WinXP on it. So I want it to look like this:

IDE 0 - 40gig Master
IDE 0 - 80gig Slave
---------------------
IDE 1 - CD-RW Drive (Master)
IDE 1 - CD-R Drive (Slave)
---------------------
IDE 2 - 500gig Slave
IDE 3 - nothing

So does anyone have any idea why when the 40&80 drives are hooked up, it shows nothing hooked up in IDE 2, but when I take the 40&80 drives out it shows up fine? Again the only thing I can think of is the jumper slots... and like I said, I know SATA usually takes master over IDE... but there is a pin slot thing on the back of the HDD, however it's OEM and I don't know where to put the pin to set it as another slave (if that is indeed the problem)

I will edit this in about 5 minutes with what I changed in BIOS.

Ok - In BIOS under "peripheral devices" I think is was... well... I changed this:

OnChip SATA - Enabled
SATA Mode - it was RAID... I changed it to IDE. When set to RAID it was never recognized. When set to IDE it will be recognized when alone, but will show up as "none" when the two other drives are inserted... which is why I am lead to beleive again it has to do with the slave/master jumper slots.

There are a few other settings like Primary Master, Primary Slave, Secondary Master, Secondary Slave and theses are for "PIO" and "UDMA" which I'm not sure what those are.

Any help would be much appreciated. Thanks

EDIT: Ive been told to remove the jumpers from my IDE drives - will this make the SATA show up in BIOS? If so, then I can just set the boot sequence to have the SATA drive boot up last and in return act as a slave... correct? Because obviously right now I can't change the boot sequence if the computer says the drive is nonexistant.

2
Contributors
1
Reply
2
Views
10 Years
Discussion Span
Last Post by fren
0

Navigate to the bios. Look for the "On-Chip Serial ATA" settings I think it is under Features Setup Page and set it at "Enhanced Mode".

Hope this helps.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.