I can run Fedora on vmware, but I cant do "install vmware tools'
So I tried to run /usr/bin/vmware-config.pl and this is what I got.
please help

None of the pre-built vmmon modules for VMware Server is suitable for your
running kernel. Do you want this program to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)? [yes]

Using compiler "/usr/bin/gcc". Use environment variable CC to override.

Your kernel was built with "gcc" version "4.1.1", while you are trying to use
"/usr/bin/gcc" version "4.1.2". This configuration is not recommended and
VMware Server may crash if you'll continue. Please try to use exactly same
compiler as one used for building your kernel. Do you want to go with compiler
"/usr/bin/gcc" version "4.1.2" anyway? [no]

My recommendation would be to try building under gcc 4.1.2 anyway. To my knowledge, gcc 4.1.1 and gcc 4.1.2 aren't dramatically different, so it's quite likely the build will succeed anyway. If it doesn't, you'll probably end up having to recompile your kernel.

just try to compile it, nothing to lose really

The problem right now is that although Fedora Core works inside vmware
I cannot increase the screen resolution since I cannot install the vmware tools

when I press "install vmware tools then the initial window comes where I press Install
and after that nothing happens.

my current resolution is set to 800x600 and the window is so small that I cant work on it.

Please help, how can install the vmware tools currectly and enjoy Fedora.

download vmtools from vmware site, and rpm -ivh it

hi, when i goto vmware server this is what I get, by I dont know what to download from here
http://www.vmware.com/download/server/drivers_tools.html

btw I run XP in the vmware too, and I can install the vmware tools inside there
but I cant do it for Fedora

It might be the image you're using.

As far as I know, there isn't a way to directly download the vmware-tools package. From VMware Server, when you choose "install VMware tools", it should automatically mount the vmware-tools CD image under your regular CD device (and in many distros, this means the VMware tools CD will appear on the desktop, I don't know if this holds true in CentOS). From there, using the command line, you should be able to use your RPM tools to install it.

it should appear in centos. anyhow, the iso file should be somewhere in the vmware directory, and it is quite simple to mount it manually and use the RPM files on it