Ok, I have a iBook G3 800MHz with just Mandrake on it, it has a ATI Radeon Mobility 7500 video card in it and I've been tweaking the XF86Config-4 file for days now and it kde continues to refuse to work :(, I've currently got it to start up but the background is red, I can see and manuver the mouse pointer fine but I can't see the dialogues because they're covered up by the red background :(, I have tried using the settings from Gentoo live cd but no luck there either, I have tried using both the ati and fbdev as display drivers and both return the red background, I've also tried adding Option=UseFBDev and still no luck, how can I get kde to work successfuly? Any help is greatly appreciated.

Thanks!

Are you logged in as root when you're doing this?

yeah I am, also I forgot to mention that the problem is worstened when I use ati as the driver, fbdev seems to be working good for me all except for the red background covering up everything, the ati driver instead makes it look all staticy and such, also when I start kde I see the X for a cursor for a brief millisecond and then the red background appears covering up any dialouges that appear including the desktop, occasionally I'll see them flash but then disappear again behind the red background, so any ideas how I can get rid of the red background and get kde to finally work? as always help is greatly appreciated.

thanks!