0

I have intall a REdhat 9.0 as a server and Ive configure to act as a DHCP server however Im having technical problems b/c the file /etc/dhcpd.conf does not exists. I went to the text edit and I created /etc/dhcpd.conf :

subnet 192.192.168.100.0 netmask 255.255.255.0 {
range 192.168.100.10 192.168.100.150;
default-lease-time 600;
max-lease-time 7200
}

Then when I run dhclient on my desktop I receive:

no DHCPOFFERS received
no working leases in the persistent database -sleeping

2
Contributors
2
Replies
3
Views
13 Years
Discussion Span
Last Post by keliy1
0

Youre kinda missing some goodies, default router.... once you have made your changes you have to restart dhcpd '%/etc/init.d/dhcpd restart' dont forget to reconfigure windows clients and setup DHCP on the LAN settings afterwards and run a ipconfig \release then a ipconfig \renew. also, make sure that your router/glorified hub or smc switch has DHCP services turned OFF

--------------sample dhcpd.conf---------------------------------
ddns-update-style interim; redhat 9.0 NEEDS THIS LINE
ignore client-updates;

subnet 10.1.1.0 netmask 255.255.255.0 {

 # --- default gateway
        option routers                  10.1.1.1;
       option nis-domain               "mycompany.com";
        option domain-name              "mycompany.com";
        option domain-name-servers      1.1.1.1; [I](your primary DNS host here, internal)[/I]
        option time-offset              -18000; # Eastern Standard Time

host servername {servername.mycompany.com;
                hardware ethernet xx:xx:xx:xx:xx:xx;[I](obtained by running ifconfig, HWaddr value for eth0)[/I]  
                fixed-address 200.180.200.199; [I](whatever you externally resolve as)[/I]
        }
}
------------------------------------------------ end--

Enjoy,

Edited by happygeek: fixed formatting

0

Thanx a lot I got it.

Edited by happygeek: fixed formatting

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.