0

Hi,
I've been trying to get SMB and SAMBA working, and I've been having a few problems. I have succeded creating a connection from my Mac (MAC OS X, v. 10.2.8 ) and Windows XP home, but I can't get it to work with Linux! First, when my Linux was on the network, I couldn't acces it because it was names "Localhost," so duplicate name error, etc... So I went into my /etc/HOSTS file, and added the line DellLin DellLin.localdomain, then changed HOST=LOCALHOST to HOST=DELLLIN in the /etc/sysconfig/network file, so that solved the //localhost problem. Now, I can only acces my Linux server from my other Linux computer. (Both are running FC2, kernel 2.6.9-1..521 and 2.6.5-1..358.) When I try to access my DellLin server from Windows XP, it gives me this error:
//DellLin is not accessible. You either do not have access permissions or access was denied. Contact you system administrator. (The network path was not found.)
I tried the Map Network Drive, too. Same error.
Any help would be really appreciated.
Firewing1
(All the config. help came previously from http://www.daniweb.com/techtalkforums/thread9598.html this site, if any want to see it.)

5
Contributors
10
Replies
11
Views
13 Years
Discussion Span
Last Post by TheOgre
0

The error you're getting is not specific to Samba; it's a Windows network error message.

1. Temporarily disable any firewall software that you might have running on the XP box; XP's built-in firewall as well as third-party firewalls from Norton, McAfee, Zone Alarm, etc. can all cause problems such as you describe. If you are using a third-party firewall, make sure to totally shut it down; sometimes simply exiting the program or clicking its "Disable" option doesn't stop the firewall entirely.

2. Check this Microsoft knowledgebase article: http://support.microsoft.com/?kbid=318030

3. Also look at the suggestions given for similar issues involving "network path was not found" errors:

http://www.google.com/search?hl=en&q=%22The+network+path+was+not+found%22&btnG=Google+Search

0

Hi,
Sorry for the delayed response.... I disabled the WindowsXP firewall, (Mind you, I forgot to disable Norton Anti-virus auto-protect, but...) and it still din't work. The weird thing is, I could access my WinXP shares form the Linux, but not vice-versa... I'm thinking of just going FTP for sharing... Is this a good idea?
Firewing1

0

FTP has security holes; I'd go with SSH instead if you're going to take that route.

Do you have valid system and Samba user accounts set up on the Linux box for all users who will be accessing the machine over the network? If not, you should.

0

I have set up the user accounts on the linux box. Also, is SSH easily accessed from Linux, Mac OS X and Win XP > That is my ultimate goal, to have my shares on the Net with user-account authentication...

>>Does it make any diff in terms of security if i'm using Very Secure FTP Daemon? (VSFTPD) with user-authen.?>>

Thanks in advance,

Firewing1

0

hello there,

I followed through replies#1-7 at "http://www.daniweb.com/techtalkforums/thread9598.html" coz Im experiencing the same problems described by cr4nberry at the above weblink.

Question: from DMRs reply 8 at http://www.daniweb.com/techtalkforums/thread9598.html,
"Sorry- I should have asked this before: are you assigning your IP info to each of your machines manually, or do you have a device (a router perhaps) acting as a DHCP server for your network? Issues of hostname problems vary depending on which addressing scheme you use."

I use a DHCP server...as in my PC accepts IP addresses dynamically.

Ive also followed Firewing1's posts, and I have the sameproblem as he does.

I use RedHat 9(Desktop) and Windows XP(Laptop). Note, I have no firewalls....as in ive not installed any..... Both are my pcs and all I want to do is to be able to transfer files in between the two.....

From my linux PC, I can see/copy files from shares on my windows PC. I cant do the same on my windows PC coz of errors......network cant be found


pls help
Toks

0

Hi Tokunbo,

First of all- welcome to TechTalk!

We ask that members not tag their questions on to a thread previously started by another member (regardless of how similar your problem might seem). Not only does it divert the focus of the thread away from the original poster's problem, but it also makes it less likely that you yourself will get the individual attention that you need.

Please start your own thread and post your question there. When you do, please try to give us as much specific info as possible regarding the problem (exact error messages, system specs, etc.).

For a full description of our posting guidelines and general rules of conduct, please see this page:

http://www.daniweb.com/techtalkforums/faq.php?faq=daniweb_faq#faq_rules


Thanks for understanding.

0

What happens when you type

\\###.###.###.###

Where the ###'s are the IP address of the remote Linux server?

0

Hi,
I havn't tried it, but it the error is //###.###.###.### is not accessible, so the same error will happen...
Also, about FTP, does it change the FTP secur. holes if im using VSFTPD?

-I use a Dell Dimesion 8200, 256 MB RDRAM, XP home...

What happens when you type

\\###.###.###.###

Where the ###'s are the IP address of the remote Linux server?

0

Firewing1,

You might want to head over to www.justlinux.com, register there, and post your question there. The site is a Linux-only support site with many helpful members; both alc6379 and I have been working there for quite some time and were actually recruited by this site's admin (Dani) due to our work there.

I'm only suggesting this because I know that we have only a small number of Linux-savy responders here, and at least three of us also have moderator duties (meaning: not a heck of a lot of spare time); you will get more "eyeballs" on your questions over at JL.

(Yikes- hope I didn't offend anyone by posting that....)

0

Did you remember to configure Samba correctly (smb.conf) by making sure that:

WORKGROUP = yourworkgroupname # name of Windows Workgroup
Security = user # can also be share

Are your shares configured for read/write access?

Example:

[public]
           comment = Public Stuff
           path = /home/public
           public = yes
           writeable = yes
           printable = no

Also, don't forget to add a Samba user (different than a local user account!) by doing:

smbpasswd -a newusername

This would be your Windows/MAC username if all machines are in the same workgroup. This is the information to use when you are asked for a username/password when attempting to access a share on a *nix box (unless you've joined it to a domain using "smbpasswd -j domain" and you actually login to an authenticating domain controller on your network.)


Another place to check is the LOGS (yes, Linux logs stuff too :). To find out where the Samba logs are located, look in the [GLOBAL] section of your smb.conf for:

log file = /var/log/logfile_name_here

Also, the /etc/hosts file has nothing to do with the local system's hostname - it's basically an easy way to define other hosts on your local network if you aren't running a DNS server.

Example:

# Sample HOSTS File
      # Syntax is:  IP		 FQDN hostname
      
      # Local LAN Entries:
      127.0.0.1		  localhost  # THIS LINE MUST NOT BE REMOVED!
      10.0.3.10		  machine1.mydomain machine1
      10.0.3.11 		   machine2.mydomain machine2
      10.0.3.12 		   machine3.mydomain machine3
       
      # Sample Entry for WAN:
      216.239.39.99	  google.com
      
      # To block annoying cookies/ads:
      127.0.0.1			.doubleclick.net

Sidenote: The Windows firewall (if enabled) won't prevent you from accessing another machine's share, but it WILL prevent others from viewing and shares on your Windows machine (just like a "regular" Internet firewall will permit a connection to return in from a request originating from behind the firewall, rules permitting ...)

Other good places (on your machine) to learn about Samba:

man smb.conf
info smb.conf
apropos smb
man smbpasswd


Home some of this helps you out. One of these days I'm going to write a Linux HOWTO book :)

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.