0

I have downloaded the tar.gz file
When i unzipped it it says samba 3. something
I go to the console and and i go to the directory where is the samba folder is locate it
And the nexty step it says to type ./configure but when i do that is say no such file or directory
any suggestions??

9
Contributors
16
Replies
17
Views
13 Years
Discussion Span
Last Post by WEATHER CHANNEL
0

It would help if you could make sure the configure files etc are all there.
cd same 3.something and from there go through the 'obvious' dirs with ls -all and read :)

0

Also another thing, how do i make the clock be on time

As root, try this:

To set your system time to 10am: date -s 10:00
To set system time to 4pm: date -s 16:00

To get the time/date, just type date

Also check the date/time after a reboot to see if the bios clock is off. You can also run ntpd (Network Time Protocol Daemon) to keep your system clock in synch with a time server. read the manpage for ntpd for more info on how to configure it.

0

simple howto on installing samba

tar -zxvf samba.foo (foo being the version)
cd samba.foo
./configure
su -
password
make
make install
cd /etc/samba
edit the samba config file with your favorite text editor.

0

simple howto on installing samba

tar -zxvf samba.foo (foo being the version)
cd samba.foo
./configure
su -
password
make
make install
cd /etc/samba
edit the samba config file with your favorite text editor.

You only need to be su for "make install", and it's better not to use the trailing hyphen when doing "su" so you remain in the same directory.

Example:

me@host$ pwd
/usr/src/samba/samba-3.0.1
me@host$ ./configure
...scrolling list of checks...
...scrolling list of checks...
...scrolling list of checks...

me@host$ make
...compiler runs...
...compiler runs...
...compiler runs...

me@host$ su
Password:

root@host# pwd
/usr/src/samba/samba-3.0.1
root@host# make install

You might also want to run updatedb after the install finishes, so you know where everything is located. The Samba configuration file is smb.conf (usually /etc/samba/smb.conf), but usually it gets installed as smb.conf.example or smb.conf.dist (depending on which platform you're on.)

When you use the hyphen with "su" all the environmental variables are loaded and applied to root's environment, like $SHELL, $PATH, $DISPLAY, and so on, and you are transferred to root's $HOME (usually /root )

By not using the trailing hyphen, you remain in the same directory, keep the same $SHELL (if root's $SHELL is different) and get what you want - root access. It's always recommended to install sudo, so you wouldn't have to go through all this to begin with. (me@host$ sudo make install)

Hope this helps to clear things up for you..

0

when i get to the samba directoy in the terminal and i type ./configure gives me no such file or directory...
i get stuck on that part
THE rom file that BOX suggested should i download the client or the server???

0

when i get to the samba directoy in the terminal and i type ./configure gives me no such file or directory...
i get stuck on that part
THE rom file that BOX suggested should i download the client or the server???

Copy the output (when you type ./configure) and paste it here. Then type pwd and paste the output here so we can see what directory you're in.

Obviously, you need to be in the correct directory or you won't be able to complete the install. If you do ls and only see one thing, it's usually the directory created when you unpacked the tarball. You need to change to that directory, do ls, and if you see configure*, you're in the right spot. Just follow the instructions that were posted before and you should have no problem.

If you want to share directories from this machine to Windows clients, you'll need the server. If you download the full tarball from www.samba.org you'll have the full installation (client and server.)

0

when i get to the samba directoy in the terminal and i type ./configure gives me no such file or directory...
i get stuck on that part
THE rom file that BOX suggested should i download the client or the server???

Look at your first SAMBA thread. Or one could reffer to my first suggestion in this thread & read my first post out of all post made by me. That is if they have that feature enabled.
When you type

./configure

and the output is no such file or directory.
One should reffer back to the main directory and one should look for a install file.(tapp the file) Granted you could read the text. named READ ME


cheers

0

I have downloaded the tar.gz file
When i unzipped it it says samba 3. something
I go to the console and and i go to the directory where is the samba folder is locate it
And the nexty step it says to type ./configure but when i do that is say no such file or directory
any suggestions??

If you have the tar.gz file, then you forgot to 'untar' it. This is similar to forgetting to unarchive a file in windows. So, use this command:

tar -xvf filename.tar


Oh, and then do the ./configure and so on and so forth.

0

If you would read my last post and paste the output you're getting so we can see it, it'd be a lot easier to see what you're doing and why it isn't working...

0

That would help! But if he/she read his/her first thread about the same question, he/she would know all he/she had to do was go in the directory/folder and click the install file.
I always install from the source when I can, it just makes life /home/thermalscript/EZ.
*hint*hint* my sticky

http://hr.uoregon.edu/davidrl/samba.html <---------(howto install SAMBA)

And with that said, it's friday, and Im gone for the night

peace.............

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.