3
Contributors
10
Replies
11
Views
8 Years
Discussion Span
Last Post by sillyboy
0

Ubuntu enables 'Emulate3Buttons' by default. You can disable it by editing xorg.conf and going to your mouse input device section.

0

Then Xorg is using its default, built-in configuration. Write your own /etc/X11/xorg.conf file, which should take care of the problem.

0

In case anyone is interested,

by default /etc/X11/xorg.conf says

"Section "Device"
	Identifier	"Configured Video Device"
EndSection

Section "Monitor"
	Identifier	"Configured Monitor"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
	Device		"Configured Video Device"
EndSection

it said to run sudo dpkg-reconfigure -phigh xserver-xorg but that just generates the same again.

i added

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "Emulate3Buttons" "false"
EndSection

and it fixed it

0

Couldnt help me with my other problem could you?

Ubunbu keeps screwing with the brightness. Boots up really dim and i have to battle with it (when i turn it up it turns it down again unless you hammer the key for like a minute after which it stays up until it randomly (seems to do it regardless of activity or time) dims it again.

0

Automatic screen brightness adjustment has to do with gnome-power-management. Try adjusting the settings in System->Power, although there have been some bugs filed with regards to gnome-power-management automatically (and incorrectly) changing screen brightness.

0

Yeah ive told the power manager not to change it ever yet it still does, and it does it regardless of whether its in battery or AC

I think it may be a kernel thing as it does it fairly soon after grub.

oddly it seems to be saving the brightness to NVRAM? , as the BIOS boot logo will be at whatever brightness i shut it down at

Possibly its a lenovo bug. Ive only just managed to get ubuntu on it, as past kernels used to cause it to overheat somehow.

0

Hurrah!!

I dist-upgraded to the bleeding-edge "jaunty jacolope" alpha branch, and it seems to have fixed the dimming issue!

And it doesn't seem to have created any problems either. I have still kept the normal Interpid repos too, so i can use apt-pinning to choose between stable or cutting edge stuff.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.