0

I have got a weird problem with text terminals. When I am switching to text terminals 1-6 with key-combinations Ctrl+Alt+F1, Ctrl+Alt+F2 ... Ctrl+Alt+F6, I am getting on my screen only white blinking vertical lines. I have added a photo attachment here. I think, that this is a matter of graphics, or something in the Linux kernel. I am running on the newest self compiled vanilla kernel 2.6.29.1. Before this kernel I was running on 2.6.28.7 and problem was not there.

Some info of my system and laptop: It is Debian Squeeze (testing) on Lenovo 3000 N200 with Intel GMA965 X3100 integrated graphic card.

Thanks and regards,
Lukas

Attachments lines.png 627.68 KB
2
Contributors
4
Replies
6
Views
8 Years
Discussion Span
Last Post by lio04
0

My guess would be a framebuffer issue. Are you using one right now (eg. is your console text smaller than, say, the text from your BIOS), and if so, what are the settings for it? You can check these in your bootloader, usually /boot/grub/menu.lst, or /etc/lilo.conf if you're using lilo.

0

Yes, I am using vga settings for widescreen 1280x800. It is vga=866. When the system is booting, it is all right. I can see everything.

0

Try booting without a framebuffer. Does the problem go away? If so, try using video=intelfb:1280x800 as your framebuffer settings instead of vga= (assuming you enabled the intelfb driver when you built your kernel).

0

Thank you bro, it was a problem with the console framebuffer. I have found it with checking all items in the menuconfig (section framebuffer) as a module. Maybe I will find exactly which item was causing this one.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.