0

Hi,

I'm running RH9 on a Dell Latitude LS400, trying to connect to my WinXP desktop. I've set up the eth0 connection on the laptop (no problems setting up, device recognised and activates without any errors.) I then set the IP addresses to 10.0.0.5 for the laptop, 10.0.0.13 for the pc, subnet masks of 255.0.0.0. I'm not trying to connect to the internet, but as the laptop doesn't have any builtin cd-rom I need to connect to the pc so that I can ftp files over. Anyway, XP recognises that there is an active network, but I cannot get any sort of communication between the two.
The only error message I get from RH is that the destination host is unreachable. Both IP addresses are manually configured.

4
Contributors
12
Replies
13
Views
12 Years
Discussion Span
Last Post by DMR
0

If you're connecting the computers together directly (that is, not through a hub/switch/router), you need to make sure you are using a "crossover" Ethernet cable; the computers will not be able to communicate if you try to connect them using a standard Ethernet cable. The following link has a bit more information on the whole "crossover vs standard" cable issue, including pictures which will help you identify the difference between the two types of cable:

http://www.aptcommunications.com/ncode.htm

0

It is a working crossover cable; I've made double sure of that.

0

Hello,

Do an ifconfig on the linux laptop, and make sure the device is properly installed, and IP numbers properly configured.

Check the XP box to make sure that interface is up and properly configured.

You should be able to ping across the two of them.

Also ensure that there are no firewalls setup. XP SP2 is enabling a firewall that could be killing the traffic.

Christian

0

As far as I can tell, I've enabled all internal traffic on XP's firewall. It won't let me (or, quite possibly I can't figure out) turn off the firewall for individual network connections, but I can tell it what packets to accept or reject. So, I've enabled all packets for the internal network while keeping the firewall for my ADSL up and running.
I've double checked the IP's, can't find anything wrong with them. To be extra sure, I switched all the IP's to a mask of 255.255.255.0 and then 192.168.0.2 and .3, but that still didn't work. The laptop and PC are just like my ex and me: refusing to speak to each other.
XP box should be set up fine as, if I plug the network cable into my work laptop with the same settings (also running XP though) I can ping to my heart's content.
mediaphyte, at this stage I'm just trying to get my boxes to ping each other.

0

The only error message I get from RH is that the destination host is unreachable.

That can indicate a problem with the route/gateway settings on hte RH box.

Open a terminal window on the RH box, type the following command at the prompt, and post the command's output for us:

route

0

1. As Christian asked, can you post the results of running the "ifconfig" command on the RH box please?


2. 169.254.0.0- * - 255.255.0.0 - U - 0 - 0 -0 eth0

The above entry in your routing table comes from DHCP auto-configuration. Since you're using staic IP addressing, it shouldn't be there. It might just be a leftover entry from your previous configuration changes, but it might also be a sign of a current conflict.

From the RH box, please post the contents of your /etc/sysconfig/network-scripts/ifcfg-eth0 and /etc/sysconfig/network files.

0

Right,

ifconfig:
eth0 Link encap:Ethernet HWaddr 00:B0:d0:88:4E:EC
inet addr:10.0.0.5 BCast:10.255.255.255 Mask:255.0.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX Packets:107 errors:0 dropped:0 overruns:1 frame:0
TX Packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX Bytes:7882 (7.6Kb) TX Bytes:240 (240.0 b)
Interrupt:10 Base address:0xfc00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX Packets:74 errors:0 dropped:0 overruns:0 frame:0
TX Packets:74 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX Bytes:4918 (4.8Kb) TX Bytes:4918 (4.8 Kb)

For the ifcfg-eth0:
USERCTL=no
PEERDNS=yes
TYPE=ethernet
DEVICE=eth0
HWADDR=00:b0:d0:88:4e:ec
BOOTPROTO=none
NETMASK=255.0.0.0
ONBOOT=yes
IPADDR=10.0.0.5
NETWORK=10.0.0.0
BROADCAST=10.255.255.255
GATEWAY=10.0.0.13

Finally, for the /etc/sysconfig/network:
NETWORKING=yes
HOSTNAME=localhost.localdomain

0

Hmm... that all looks good to me; I'd think you should at least be able to ping at this point.

Just to really eliminate this possibility- turn off XP's firewall entirely. After disabling the firewall it might be a good idea to reboot just to make sure that all components of the firewall have been shutdown. If you're worried about leaving yourself vulnerable, just physically disconnect the XP machine from your DSL modem during the test.

0

Gosh how I love windows. Turned XP's firewall off and bingo, the two start talking. So I turned the firewall back on again, and they're still quite happy to carry on speaking to each other. But now my main problem is solved, so I can ftp to my hearts content, and also figure out for myself (at least at first) how to enable the internet connection sharing via XP's all too contrary firewall. Thanks for all the help!
Davis.

0

Gosh how I love windows. Turned XP's firewall off...

I know what you mean. I've had more weird, flaky experiences with that @#$*% firewall than I care to think about....

Glad you at least got it happening, though. :)

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.