0

Hello, everyone - I am the system adminstrator at a small company running 13 workstations with XP Pro, and am in the midst of installing SP2 to all workstations. The installation has gone smoothly on all but 2 stations; the two in question are giving me an error about 3/4 of the way through the installation saying "Unable to read from or write to the database". I have tried the following Microsoft-provided solutions to no avail:

1) ran ESENTUTL on secedit from cmd prompt
2) Renamed the Edb.log file to have .tst extension
3) Made sure Cryptographic services were set to automatic
4) Renamed the Catroot2 folder to oldcatroot2
5) Reregistered cryptographic services DLL files

Any ideas or suggestions would be most appreciated. Thank you so much!

4
Contributors
9
Replies
10
Views
13 Years
Discussion Span
Last Post by DMR
0

Well, since no one else has responded to this, I may as well put in my two cents. Is there an error code with this message? That may be helpful. Are you sure these two systems meet the minimum requirements for SP2? Check this thread to see:
http://www.daniweb.com/techtalkforums/thread10031.html

There must be something different about these two systems from the others.

I found the following info at:
http://www.michna.com/kb/WxSP2.htm#Cannot_install_Service_Pack_2

I know you've tried some of this already, but maybe there's something here that can help.

Error 0x800710D9 Unable to read from or write to the database
The quickest and most thorough way to solve this problem is a batch file, written by fellow MVP Torgeir Bakken from Norway. Reboot the computer and, before running any other program, run the batch file. It will tell you when it is finished. Here it is: fixdb.bat

For other possible solutions check http://www.updatexp.com/cryptographic-service.html and the following Microsoft Knowledge Base article for details.

You cannot install some updates or programs
http://support.microsoft.com/?kbid=822798

The most successful workaround for the cryptographic service error has been the method 3 mentioned in that article:

Rename the Catroot2 folder, and then try to install the program again. To rename the Catroot2 folder, follow these steps:

Click Start, and then click Run.
In the Open box, type cmd, and then click OK.
At the command prompt, type the following commands, pressing ENTER after each line:
net stop cryptsvc
ren %systemroot%\System32\Catroot2 catroot2old
net start cryptsvc
exit

Important: Do not rename the Catroot folder. The Catroot2 folder is automatically recreated by Windows, but the Catroot folder is not recreated if it is renamed.

For the "Error 0x800710D9 Unable to read from or write to the database" you would need to delete or rename the %systemroot%\Security\*.log files as well (rename them to e.g. *.log.old).

If all else fails
You can try to install Service Pack 2 in safe mode.

Good Luck!

0

Thank you, dlh6213. Yes, I am sure that the two computers in question meet the minimum requirements for the update. Unfortunately, there is no error number displayed with the message; that sure would have made things easier. I will try your suggestions today and let you know how things worked out. I really appreciate your help. Thanks again!

0

Fixdb.bat worked for me - huzzah!

I simply downloaded and ran the batch file, reebooted and retried the SP2 install - and all's well.

Thanks to the author and dlh6213 for recommending it,

EchoMan

1

Happy it helped you echoman, hope it works for whiskeyjar as well.

Votes + Comments
Good job- thanks for helping out here!
0

Hello again, dlh6213. I haven't had the time yet to work on the pc's in question; I'm hoping to re-address the problem sometime in the coming week.
I just noticed your new post and echoman's positive results, so I believe that I may try that route first. I greatly appreciate your help and your feedback.

0

Well, dlh6213, I just wanted to extend my gratitude to you for the tip about the fixdb.bat.
I ran it and SP2 installed flawlessly.
Thanks so much for your help. :cheesy:

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.