0

Hi, I've been trying to figure out how to log on from my xp box to the samba server running on a redhat 9.0 box.

Everything seems proper, I can access locally from the linux box and
the xp can see the samba server too. When I double click from the work group, it prompts for the user name and passwd, so far so good. BUT
I CANNOT LOGON!

The log file prints out the following:
[2003/12/23 01:26:45, 2] smbd/password.c:pass_check_smb(575)
pass_check_smb failed - invalid password for user [solo]
[2003/12/23 01:26:45, 1] smbd/reply.c:reply_sesssetup_and_X(1001)
Rejecting user 'solo': authentication failed

I am using exactly the same user and passwd from linux to access the samba server, and it works from there.

Here is my smb.conf, the passwd was generated using smbpasswd
I've googled all around, nobody else seem to have this problem, so I
must be doing something very wrong. Also the XP box does not require
a passwd to logon, just in case it matters.

any help is greatly appreciated, thx,
-solo

------------------ smb.conf -----------------------
[global]
workgroup = Home
server string = Samba Server
hosts allow = 192.168.1. 192.168.2. 127.
log file = /var/log/samba/%m.log
log level = 2
max log size = 0
security = user
encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
dns proxy = no
[music]
comment = Music
path = /share/Music
browseable = yes
writable = no
public = yes
create mode = 0664
directory mode = 0775

5
Contributors
5
Replies
6
Views
13 Years
Discussion Span
Last Post by ibi001
0

try encrypt passwords = no in your smb.conf and restart samba.

does that make a difference? Also, is your XP username solo? I've had a lot of trouble accessing Samba shares as a different user than what my current XP username is...

0

How many computers are on your network anyway? If there is only 2 then why is your hosts allow set up so odd?

0

You need to add a samba user to the samba server. Normally, whatever you use as a login on your WinXP box shold be added to your *nix box by doing:

smbpasswd -a username

If you use a password on your WinXP box, make it the same password in samba so you won't have to login to access the samba shares.

For example, if I use "TheOgre" on my Windows machine with a password of "password" and I want to access network shares on my *nix machine, I would add a normal user account to my samba server called "TheOgre" and set a password called "password." Next, I'd create a samba user called "TheOgre" and set the password to "password" (matching my Windows login.)

Create a user account on your *nix box (different distro's use different methods, so i'll skip it here, assuming you know how to do that already.)

To create a samba user, follow this example:

smbpasswd -a TheOgre # The -a switch is for "add"
Set a password for the new samba user when prompted, then you're done.

Next time you want to access a network share, and you're logged in to your Windows box with that username, you won't be prompted to enter a username/password.

If all else fails, check the manpage for smbpasswd (man smbpasswd)

Hope this helps!

0

actually everything now works fine, no config is changed,
just a few reboots? have no idea why it worked now, yet another xp mystry for me. Thanks for your replies.

0

I had the same problem logging in with windows... I had a standard id and
standard password and still it would not let me in... Maybe I didn't add
the correct user id for samba ????? Windows would not let me in....
I had security turned off and it still would not allow my password to take effect...
I will do what u said above and see what happens....Thanks much.... There
should be some type of edits to know that the user id and password
submitted will work.... Don't u think....

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.