0

ATTN: VMWare users!! Please help me! ...

(sorry this post is so long, I tried to be very thorough)

I have a WindowsXP computer with two nic cards. One of them is connected to a cable modem and another to a hub. Also connected to the hub are a linux box and a Windows98 laptop.

This linux box is a P4 with a linksys gigabit network card (10/100/1000mbps) and RedHat 7.3. The internet works perfectly and samba is set up so the linux box is a full participant in Network Neighborhood (can see both Windows pcs).

... I have a VMWare emulator installed on this linux box running Windows 2000.

When my virtual machine uses NAT networking, I can browse the internet, etc. When I browse Network Neighborhood, the Win2k machine is the only machine showing up on the network.

When my virtual machine uses bridged networking, I can browse Network Neighborhood with no problems. Network Neighborhood shows the Win2k machine, the RedHat machine, the WinXP machine, and the Win98 machine. However, there is a problem sending/receiving data packets over the Internet.

Communication between the virtual machine and the host linux box works perfectly (e.g. when I ftp to the linux box or browse files via Network Neighborhood). However, connection to any of the other computers OR to any part of the internet doesn't work so great - my upload speed is perfect, but my download speed is at a whopping 0.6kbps !! I *can* ping some www sites but that's just about it. When I open my browser, IE says "Web Site Found. Waiting for Reply" and then just stays at a blank page until it eventually times out. When looking at my network properties, I end up with statistics such as: 700packets sent, 4 packets received.

What is most puzzling is that this used to work with the exact same setup (prior to a recent reformat). In fact, I saved the virtual machine disk on a linux partition and simply re-used it without changing anything. Therefore, I am positive that it can't be anything on the Windows end. It has to be something in Linux.

I am thinking that some sorta program on linux's end is blocking packet transfer from other computers (other than itself) to the virtual machine. My firewall is set to automatically accept all traffic to/from the eth0 nic. (But what about the virtual nic? Is this one firewalled??) I even tried disabling my firewall altogether and that didn't help.

HELP MUCH APPRECIATED !!

3
Contributors
6
Replies
10
Views
15 Years
Discussion Span
Last Post by Dani
0

ok, this definetly does NOT fall within the realm of my expertise, but two things come to mind. one, from what i understand sometimes multiple nics in a box can cause communications probs in that a connection can loose focus on which nic its using - so maybe using different protocols on each nic might help? 2nd, what kind of a hub are u using? a regular (dumb) hub may not be the best solution - a smart hub or switch? I'm really not sure on the hardware end of things, so i'm not sure if i'm making sense or simply making the age old adage true that a little knowledge can be a dangerous thing!

0

Sorry aeinstein, but this issue has nothing to do with a hub or a switch (and I believe she has a switch). The second network adapter is a virtual one, created by VMWare, and VMWare gives you the option of how to connect it to the first, by network address translation, or by a bridge. I don't know an answer, because I've never encountered a problem before.

0

well at least i'm right about the age old adage thing then.... interesting tho that if you don't know what's causing the problem that you can unequivocally rule out the possibility of a hardware/firmware issue (ok, ok, SO i'm a sore loser!!! ;) )...

0

ok, now that i've stomped my feet a bit let me just mmake a coupla comments. in troubleshooting a tcp/ip connection i pinged pc A and logged approx 20% packet loss; the moment i started pinging pc A's immediately preceding csu/dsu type device, pc A's nic packet loss dropped to 0%, and remained that way even afteri stopped the other ping. nobody could ever tell me the why's on that one. situation 2: pc A has approx 30% packet loss @ nic; ping against csu/dsu type device shows approx 25% loss. normally process is to t/s csu/dsu, which can get expensive; on a fluke i decide to rebuild tcp/ip on pc A - packet loss goes to 0% on both devices. out of approx 200 or 300 similar instances rebuilding tcp/ip on client cleared up packet loss issues twice - it should NOT have worked at all since the pc stack has nothing to do with the csu/dsu. sometimes things arent simply just black and white!

0

Hmmm ... thanks for the suggestions. To be perfectly honest, I honestly sincerely think the problem is a combo of an uncommon gigabit network card and RedHat 7.3 (VMWare claims only up to 7.2 is supported, but it has always compiled and ran on 7.3 with no problems). In other words, not something on my end that's going wrong.

The problem started happening, originally, when I got my gigabit nic. (In fact, I remember VMWare working. Then I turned off the PC, swapped nics, turned the PC back on, and VMWare began to hate me.) Then I reformatted, and it actually worked ... but it was an ultra bad install and I royally screwed it up within minutes, and reformatted again, and it didn't work! I really think it was just a fluke that it worked.

Oh well. :/

0

It works now?! No clue what I did ... but I'm back to having the problem w/ NEAT (redhat's network admin tool not working) => it seems to be one or the other *sigh*

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.