0

HI all,

I am new to linux envitoment. I installed ubuntu 12.04 server edition.
First I installed apache2 and tried to run a web site specially drupal site. I was unable to do that as some file permission errors.
how ever I removed apache2 and now I install lampp for linux 1.8
I stil have the problem, I log in teminal as root (whoami)
but when I try to create a folder with GUI it says no permission.

problem is IF I am root then what permission again?
other problem is, isn't it enogh to log through terminal and do stuff with gui?

I am a windows user. and I have get errors when I run drupal on apache2 since file permission errors.
plz some one help me to correct this.

I have go through several articals and gave different permission to folders but didnt work.

thx in advacne..

2
Contributors
1
Reply
3
Views
5 Years
Discussion Span
Last Post by rubberman
0

Even root can be protected (prohibited) from creating files or sub-directories if the permissions of the directory are so set. Make sure that the directory is owned by root and has read+write+execute permissions for the owner. You can do that with these commands:

chown root dirname
chmod u+rwx dirname
This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.