Help instaling linux fedore 17 from usb?

I have a laptop that came out with windows 7 basic, i installed backtrack 5R2 over it but now i want to install Fedora 17 over backtrack. My laptop doesnt have a CD rom so i use usb. Now when i try to install fedora 17 it boots and displays this msg :

syslinux 4.06 edd 4.06-pre1 copyright (C) 1994-2011 H. Peter Avin et al

I dont know why it does this. I can install fedora 17 becuase it doesnt want to boot further.
I have also tried this with other OS including: fedora 16, ubuntu server 12, windows 7 basic.

They all give that msg and nothing happens further. It has never done this before it is just now...
How can i fix it?

5 Years
Discussion Span
Last Post by tinstaafl

Have you tried using one of the many boot disks available that will work on a usb stick, and totally erase the partition(s) and start right from scratch?


Sounds like even if it is, something was done in the original install that got corrupted and subsequent installs aren't removing it. Using a different utility to clean it up first might help.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.