0

I am unable to write a text file from a windows PC to a folder in Unix. I am told I have no permission. I can see the unix server from network and browse to the folder but I cannot write to it. The permissions of the folder on the unix is drwxrwxrwx.

How can I agrant rwx permissions of a unix folder to a windows user. You kind assistance would be appreciated

2
Contributors
5
Replies
18
Views
3 Years
Discussion Span
Last Post by CimmerianX
0

So in the smb.conf you should have a section for the Share that you are having issues with.

Something like:
[Share]
path = /blah/blah
valid users = user
browseable = yes

Check to see if you have a "read only" entnry set to yes in the section.

That would be my 1st guess.

0

I have below in my smb.conf
[Data]
path = /gc/cust/valco/data
read only = No
writable = yes
guest ok = Yes

Is samba case sensitive? will add valid users and see the response I will get. Secondly if I have a user on a windows domain like e0152@valcotema, how can I add that or the user should be set up in the Unix?

0

I'm not not sure if it is case sensitive actually.... I always use lower case in conf files though. Did you change it, what was the result? Now I'm curious about that.

You have to add users to the local host in order to have them access the share when using the "valid users" parameter

smbpasswd -a johndoe

[Share]
path = /blah/blah/
valid users = johndoe
read only = no
browseable = yes

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.