0

I have installed VMware 3.2 with the 30 day license on a Red Hat 8.0 machine with XP on the other partition. I run vmware-config.pl and get this error: Making sure VMware Workstation's services are stopped.

Stopping VMware services:
Virtual machine monitor [ OK ]

Trying to find a suitable vmmon module for your running kernel.

None of VMware Workstation's pre-built vmmon modules is suitable for your
running kernel. Do you want this script to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)? [yes] yes

Using compiler "/usr/bin/gcc". Use environment variable CC to override.

Argument "\x{67}\x{63}..." isn't numeric in numeric ge (>=) at /usr/bin/vmware-c
onfig.pl line 1493, <STDIN> line 1.
What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux/include] /usr/include

The directory of kernel headers (version 2.4.9-9) does not match your running
kernel (version 2.4.18-24.8.0). Even if the module were to compile
successfully, it would not load into the running kernel.

What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux/include]


Any suggestions?

3
Contributors
10
Replies
11
Views
14 Years
Discussion Span
Last Post by Z28James
0

Did you try continuing with the setup (e.g. hitting ENTER and letting it compile the module)?

RedHat 8 isn't officially supported by VMWare (although Redhat 7.x is). However, I'm running VMWare on Redhat 8 with no problems. I had to compile the module myself, however. I couldn't use any of the pre-configured modules.

When the setup directory asks, point it to the location of the c++ header files, a compiler, and let it get to work.

0

Sorry, this is going to be a newbie question, but isn't /usr/include/ pointing to the header (if I point it anywhere else it asks me for a "linux", "asm" or "net" in the folder)? gcc is in /usr/bin/ and I tried pointing it there (which I figured wouldn't work bu tried anyway). I searched through the help at vmware and got nothing. you are my bright shining hope.

0

Unfortunately, with me it found the header files it needed to compile in the default location. According to the error message you're getting, it says that it found older header files but not ones compatible with the current kernel you're using. Did you upgrade your kernel? Perhaps you didn't install the kernel source code when you upgraded??

0

I tried using the default location and got "the folder does not exist." /usr/include was the only folder that had a "linux" folder inside it. I upgraded the kernel using up2date shortly after I installed. Up2date is telling me there is a new kernel update available now. I guess I am going to have to try it on another system than this one.

0

Aside from updating the kernel, be sure to update the kernel-source at the same time. (both should be the same version number).

Kernel source code is what allows you to compile programs for your kernel. (I believe?)

0

okay. That sounds like it might be the answer. I guess this will be another newbie question, but how do I do that? I installed the kernel update using up2date last night and assumed that the new kernel compiled itself when I rebooted. I am looking through my Red Hat book and find that I am mistaken. I will work through it according to my book, but in the meantime any help you can give would be, well, helpful.

0

Well, if you remember when you originally installed RedHat, you were provided with a list of available packages to install. One of them was the kernel-source package.

If you had an older version of kernel-source installed, RedHat's up2date should have given you the option to install the updated kernel-source at the same time as the updated kernel.

Otherwise, just go to redhat.com and login (I assume you have a username/password considering you use up2date). Then go to the errata page and you should be able to download the kernel-source package from there (as a good ol' .rpm) Do a search for it and it should turn up. Just make sure the version you install is the same as the version number of your kernel.

Then, browse to the location that you saved the file at and type

rpm -Uvh kernel_source.rpm

(or whatever the file happens to be named)

0

I always thought red hat said it was a nono to update the kernel using up2date


also /usr/src/linux is just a symbolic link that points to your current kernels source and its probably still linking to the old kernel source. in the /usr/src directory you should see the folders containing the different kernel source.

another solution is to use the new vmware 4 beta..it comes with a pre-built module for the kernel you are running.

0

thanks. i have been distracted with other things and have not been able to try these things out but should be able to get to it shortly.

another newbie question, why does red hat suggest to not update the kernel using up2date?

0

to be honest im not sure but i remember seeing something how you were suppossed to set it so it didnt update the kernel and kernel source when i was using rh8

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.