0
me@MYFIRSTNAME-Ubuntu:~$ cd ~/tux*
me@MYFIRSTNAME-Ubuntu:~/tuxlol-0.1-dd62ba8-bin$ mono tuxlol.exe patch --dir "~/.PlayOnLinux/wineprefix/LeagueOfLegends/drive_c/Riot\ Games/League\ of\ Legends/"
The specified directory is invalid.
me@MYFIRSTNAME-Ubuntu:~/tuxlol-0.1-dd62ba8-bin$ ll
total 384
drwxrwxr-x  2 me audio   4096 sep 29  2013 ./
drwx------ 27 me me      4096 apr  5 16:03 ../
-rw-rw-r--  1 me me     84480 sep 15  2013 CommandLine.dll
-rw-rw-r--  1 me me    225280 sep 15  2013 ICSharpCode.SharpZipLib.dll
-rw-rw-r--  1 me me     11264 sep 29  2013 tuxlol.exe
-rw-rw-r--  1 me me       933 sep 15  2013 tuxlol.exe.config
-rw-rw-r--  1 me me     15872 sep 29  2013 Xargoth.TuxLoL.Core.dll
me@MYFIRSTNAME-Ubuntu:~/tuxlol-0.1-dd62ba8-bin$ cd ~/.PlayOnLinux/wineprefix/LeagueOfLegends/drive_c/Riot\ Games/League\ of\ Legends/
me@MYFIRSTNAME-Ubuntu:~/.PlayOnLinux/wineprefix/LeagueOfLegends/drive_c/Riot Games/League of Legends$ ll
total 208
drwxrwxr-x 4 me me     4096 apr  5 16:04 ./
drwxrwxr-x 3 me me     4096 apr  5 02:08 ../
drwxr-xr-x 4 me audio  4096 apr  5 16:06 Logs/
-rwxrwxr-x 1 me me    90112 apr 26  2011 lol.launcher.admin.exe*
-rwxrwxr-x 1 me me    90112 apr 28  2011 lol.launcher.exe*
drwxrwxr-x 7 me me     4096 apr  5 16:06 RADS/
me@MYFIRSTNAME-Ubuntu:~/.PlayOnLinux/wineprefix/LeagueOfLegends/drive_c/Riot Games/League of Legends$ 

I tried to install one of the games that I play. This is not "patch" as in program that cracks programs for free usage, game I'm installing is totally free, but according to many many tutorials, Wine "can't handle mipmaps smaller than one block", so it needs that program called "TuxLoL.exe" to be executed. I know that surely none of you play this game or even need it, but maybe there's something wrong with permission, settings or any other things that might say "no" to TuxLoL? I posted shell actions above.

I went Googling for solution, there are other people that had the same problem, but they either solve it by another command, which produces same result for me, or they say "follow [this] tutorial! if you follow, it will work", but it's either tutorial I just used, or another copy of another copy from the one that my tutorial has been copied off.

No real solution found. Is this error of TuxLoL, Ubuntu, the game, or mine (most likely)? And is there a way to fix it?

Edited by RikTelner

2
Contributors
2
Replies
19
Views
2 Years
Discussion Span
Last Post by RikTelner
1

On Linux systems, double quoting a directory or file name will deal with the spaces. IE, your adding "\ " values to the string are problem causing this error. So, the string probably should be this: "~/.PlayOnLinux/wineprefix/LeagueOfLegends/drive_c/Riot Games/League of Legends/"

0
me@MYFIRSTNAME-Ubuntu:~/tuxlol-0.1-dd62ba8-bin$ sudo mono tuxlol.exe patch --dir "/home/me/.PlayOnLinux/wineprefix/LeagueOfLegends/drive_c/Riot Games/League of Legends/"
The specified directory is invalid.
me@MYFIRSTNAME-Ubuntu:~/tuxlol-0.1-dd62ba8-bin$ 

Darn it!

Votes + Comments
sudo make me a sandwich
This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.