I recently built a crypto currency miner and I'm using Linux Mint as my OS for the miner. I manually turn on the miner by navigating to ~/Desktop/claymore and running ./start_only_eth.bash and my miner starts mining. So i palced this line ./home/ethereum/Desktop/claymore/start_only_eth.bash in the /etc/init.d/rc.local file but I don't think it's running. When I type ps or ps -aux | grep /home neither ps command shows that my miner is running. What am I doing wrong with my auto startup stript?

Also, how can I setup my miner so that the computer will always be on? Meaning, if the power goes off and is restored it will turn itself back on as long as there is power without me having to maunally push the button? Thanks all.

Recommended Answers

Not the answer but in my mind the line may not belong in that folder.

I don't have a Mint system to work along with you on this but if I had to do this, I'd research with this:

Jump to Post

All 3 Replies

RTFM! This is a simple system configuration setting, to instruct the system to restart on power-on. If you can't figure it out by yourself, you should not be doing what you are trying to do! Google will help...

Noted.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.20 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.