0

(short version of the story)

I'm using Kubuntu in BIOS Legacy State as this was the only way I could see USB option in Boot Menu (F12). And it was the only way I could install Kubuntu from USB, from boot. I "burned" USB using OEM Windows 10 and told Kubuntu to take entire disk (effectively wiping out all bloatware).

If I enable BIOS UEFI mode, I see "No Bootable Device" icon because Linux and UEFI don't like one another(?), and already mentioned, list of bootable devices disappear (In Legacy Mode, there are 5 positions, HDD, USB, network etc., in UEFI mode, nothing, empty list).

I ran: dd bs=4M if=/path/to/win10.iso of=/dev/sdx && sync
with correct path and correct USB and it didn't work. Screen flickered couple times and the only thing I saw was Kubuntu's logo and it booting up. WinUSB is not a choice since it's seemingly offline, unetBootin never worked. I'm not aware of any such easy tools.

I don't know what to do, is it possible to install Windows 10 on Legacy BIOS from USB on Linux?

Any ideas? How can I successfully "burn" USB, boot it and actually install it?

Currently my computer is in Legacy BIOS mode, with enablable UEFI mode with Secure Boot disabled.

After dd I can easily reformat my USB (which means it's not hardware failure) and reuse it. Could someone knowledgable guide me?
I have two iso's actually, one from Windows 10 and one from Windows 7 (oldie but goodie).

I don't know what to do.

2
Contributors
7
Replies
50
Views
9 Months
Discussion Span
Last Post by Aeonix
0

Sorry but the last time I did this I used MSFT's tool at http://wudt.codeplex.com/

Now some .iso's do not work on USB so you have to test that out. I used the old ODD (optical disc drive) to be sure my ISO worked before I did the USB test. And to make matters more fun, BIOS issues. I don't own your PC so I can't tell you the settings to use for 7 and 10. I know on 7, uefi is the pits at times.

0

I'm sorry, but I don't know what to pull from your post. I'm on Kubuntu, I can't run the program from codeplex and virtual machines don't make partition changes to physical USBs.

So, everything is gone, I need to use 3rd party to get Windows forced onto my HDD? Well, that sucks.

Edited by Aeonix

0

You wrote "WinUSB is not a choice since it's seemingly offline, unetBootin" so I shared what I used last time. Once in a while you have a client that has no Windows machines at all so you get the files from them and make it for them. I understand that but I'm a bit of a lazy bum. That is, if I find I need a Windows machine, that's what I use. I am agnostic about OSes.

0

About virtual machines don't make partition changes to physical USBs. I recall doing that years ago. It was long ago but today I stick with a bootable copy of GPARTED when I need to edit partitons.

0

Page you provided while interesting, shows only how to burn Linux on Linux, how to create multi-boot on Linux, how to create Windows PE on Linux and how to burn Windows on Windows. But not how to initiate booting of Windows NT on Linux. Nothing on alternative methods of burning Windows on Linux.

Not a real solution, but I appreciate the effort.

0

I hoped that there were alternative ways to burn USB, but I bought DVDs and installed Windows this way, then I just installed grub back, and now I'm where I wanted to be.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.