0

hey all, I've never been in this forum before; but then I've only just got into using my Linux PC.

I'm using Mandrake with mostly KDE sessions, and I'm having a bit of trouble figuring out how to do something that seems simple... I have only got old(er) web browsers on here, so I figured I'd download Firefox version 2; downloaded, unzipped, now I have a load of files and I don't know what to do with them.

All the ones that "look" like applications don't do anything when I open them: I'll get a question "Do you really want to execute 'file:/home/matt/firefox/firefox-bin'?" and then nothing...

do I have to move them somewhere, or do something to get them to be applications? there doesn't even seem to be an "install" file..

firefox website isn't helpful, it has an "installing the application" section; but all it really says is "first, install the application" =P

4
Contributors
11
Replies
12
Views
11 Years
Discussion Span
Last Post by BillBrown
0

Firefox for Linux doesn't have an installation program. You can either run it from where you unpacked it, or you can move it into where it's typically installed, which is /usr/share/.

To actually run the program, simply run firefox found in the main folder. If it fails to run or something, do you have an i686 processor (Pentium 2/3/4 or equivalent AMD)? Firefox is only built for those kernels, and if you have something older, it won't work.

And yes, you're right about the Mozilla documentation for Firefox on Linux. It absolutely sucks.

0

well, i unpacked it twice, once to /home/matt/ and once to /usr/local/bin/ as an online walkthrough guide suggested i should put it there... i unpacked it twice, once using the GUI unpacker that comes with Mandrake and once using the command line. same thing happens both times, it looks ok, but running the firefox script in a terminal or from a menu shortcut gives me an "opening firefox" taskbar item with an hourglass, then it shortly disappears and nothing happens...

another online source suggested it might be a dependancy issue, but the instructions in that one don't seem to be bash commands, and i can't for the life of me see how to find out what the missing dependancies are :/

my linux pc is within those specification ranges, i don't know exactly but i think it's a (Celeron) P3 equivalent.

the version of linux that came with the distro works ok, but apparently it's a version that pre-dates the auto-update feature..

0

ahhh... just got Opera to work instead. it's much easier (but by no means "user friendly") with RPMs.. I had to satisfy some dependancies (stdc++5) but, at least i was informed what those dependancies were =P.

methinks that, for now atleast, Mozilla have lost this part of the "Linux n00b" market.

0

Well, only kinda. The problem here is that Firefox 2 just came out, so a lot of the distrobutions don't have a package put together for it, where as opera, makes their own packages. OS's like gentoo already have it easily accessable though :)

0

Although I'm using Firefox 2.0 on Mac OS X, I'm unable to use it on Debian, as it runs, but doesn't allow me to use the Enter key to go to a website, so I must manually press the "go" button each time I enter a URL into the address bar... very annoying. Firefox 1.5 doesn't have these issues though, so that's what I use on Linux.

0

Hey Matt.. I'm curious. Did you ever get this worked out~? If you did, are you enjoying version 2~?

0

I did get it to work eventually, although it wasn't by trying to install it... I installed some other applications and in satisfying their dependancies I satisfied whatever it was Firefox was looking for.

To be honest, I don't see many differences between this FF and the one I had on my other PC,, (1.X), although, maybe its faster... Then again, this PC works much faster than my Windows laptop anyway..

I do use Opera mostly at the moment.

0

I've been using FC4 for a little while but Mandrake/Mandriva for years prior to that. I've usualy been able to find RPMs for newer or less mainstream packages at DAG.

http://dag.wieers.com/packages/

Maybe have a look there next time you're looking for something if you haven't already.

0

The thing I have problem with now is things that come uncompiled... sometimes I get a good thing and have no problems (Apache worked fine) other things just explode when they hit GNU C++... I don't know if its actually serious problems with the programs I've tried to install, or the G++ being too strict for its own good....... but nonetheless.. it's annoying.

I can't get Hydrogen (http://www.hydrogen-music.org/) to work.. and I'd really like it to; but it only comes uncompiled, and blows up on G++ and the Intel C++ compiler... I spent hours trying to get that to work, so maybe that's when I satisfied the FF dependancy...

0

Hey that looks pretty neat. I"ll try to install it this weekend and get back to you Tuesday with how I did (I could actually use that one). I bet we can get it workin' for ya.

0

Hey Matt,

Unfortunately, in large part due to being on call this weekend, I didn't have a chance to work on the Hydrogen application. I certainly will though and let you know what progress I make. I could actually make extensive use of it myself so I'd love to get it working too.

.Bill

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.