0

Hi, folks!

I recently forced to upgrade my systems from RHEL3 to RHEL4, due to new software requirements, and now I'm having some weird problems with Samba:

1) When I mount Windows shares using smbmount, I can write to a share normally, but if this share contains many files (I still don't know exactly how many files) and I try to list them (using ls or find, for example) the system hangs completely, with no errors displayed or written to logs.

2) Searching on Internet, I read that SMBFS on RHEL4 is a little buggish, and the right way to mount Windows shares is using CIFS. I tried to mount the same shares using mount.cifs and was mounted ok, but when I try to write something, I receive "Input/Output error". When I try to list the files, I receive "CIFS VFS: No task to wake, unknown frame rcvd!".

I choose to use RHEL at my company expecting stability and working packages, but now it seems I was wrong...

Thanks in advance!

Reginald0

2
Contributors
3
Replies
4
Views
10 Years
Discussion Span
Last Post by jbennet
0

Using standard 4, but already tried with QU4, with same results.
Now at least I could isolate the problem: That specific machine that share the folders is a SnapServer (www.snapserver.com) that has a system called SnapOS, which sharing functionality is similar to a Windows 2000, but nothing was changed in that machine, so my big complaint is why was working before the upgrade and not now?
I'll make more tests with that machine and keep you informed.

0

that might be a security issue

different systems have different SMB/CIFS implementations.

e.g MacOSX needs to connect above a certian port, windows nt requires encrypted passwords, older linuxes require plain text etc....

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.