0

Okie, I'm just finish configure my postfix. My postfix is MTA for my MUA Squirrelmail. I'm using Linux RedHat 9.0 OS.

Somehow I'm only able to send mail but not able to receive mail.

Plus I recognize when I send mail to a mailbox to such as Bellsouth.net or yahoo.com.. I see the header of the email state as user@localhost.mydomain.com. I want to change it to such as :

user@mydomain.com, and how do i do that?

And what configuration that I need to implement in the main.cf file for my MUA Squirrelmail to be able to receive mail from the outside source? Because at the moment I only can send mail.

Any idea anyone ? :) ... Appreciated.

4
Contributors
3
Replies
4
Views
14 Years
Discussion Span
Last Post by sasso
0

Okie, I'm just finish configure my postfix. My postfix is MTA for my MUA Squirrelmail. I'm using Linux RedHat 9.0 OS.

Somehow I'm only able to send mail but not able to receive mail.

Plus I recognize when I send mail to a mailbox to such as Bellsouth.net or yahoo.com.. I see the header of the email state as user@localhost.mydomain.com. I want to change it to such as :

user@mydomain.com, and how do i do that?

And what configuration that I need to implement in the main.cf file for my MUA Squirrelmail to be able to receive mail from the outside source? Because at the moment I only can send mail.

Any idea anyone ? :) ... Appreciated.

Don't know if you've ever come to a conclusion on this...I know the solution...it's in my notes...but notes at a different terminal than I'm able to get to right now. I'll give this resolution if you haven't already.

TKS

0

I don't know about postfix, but in sendmail, it's controlled through /etc/aliases. That may be the same way in postfix, as a lot of MTAs are sendmail syntax compatible.

In /etc/aliases, you just map the username to the email address you want. On my system, it looks like:

alc6379 : [email]alc6379@this.isnt.my.real.e-mail.host.com[/email]

Then, all of the mail would look like it came from alc6379@this.isnt.my.real.e-mail.host.com, not alc6379@localhost.localdomain.

Regardless of the file, I'll bet it's called a mail alias. Maybe that search term will help in your studies

0

Okie, I'm just finish configure my postfix. My postfix is MTA for my MUA Squirrelmail. I'm using Linux RedHat 9.0 OS.

Somehow I'm only able to send mail but not able to receive mail.

Plus I recognize when I send mail to a mailbox to such as Bellsouth.net or yahoo.com.. I see the header of the email state as user@localhost.mydomain.com. I want to change it to such as :

user@mydomain.com, and how do i do that?

And what configuration that I need to implement in the main.cf file for my MUA Squirrelmail to be able to receive mail from the outside source? Because at the moment I only can send mail.

Any idea anyone ? :) ... Appreciated.

this is an old post, but i recently found it when i had a similar problem with the "localhost".myspecificdomain.com appearing in the "from" field. i hope this helps anyone that might be looking...

i set up RH FC2 with dovecot, postfix and squirrelmail. i also setup webmin because i'm not really a unix guy and it helps me a lot.

i used the command "system-switch-mail" in a terminal to switch from sendmail to postfix for my mta.

using webmin, i went to servers -> postfix -> general options
changed "what domains to receive mail for" to my specific domain
changed "network interfaces for receiving mail" to all
click save and apply

you should automatically return to the webmin postfix config. then click "Address Rewriting and Masquerading"

change "Address masquerading" to "$mydomain" (this removes the "localhost" from the sender/"from" address)
save and apply

restart postfix by clicking "stop postfix", wait for the page to reload and click "start postfix".

hope this helps. sorry if it doesn't...

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.