Hi i am new here.

REcently i began to download a few software from the internet and must of them are in zIp files. When i try to open them, textedit open instead and it says this program cannot be run in DOS mode. I do not know how to turn it off. From what i heard there is not a DOS mode in mac, so why does this sign appear.


Welcome Roy,

Never heard of a DOS mode on a Mac either. Maybe with Windows installed? Totally ignorant of that realm.
You can use Zipeg, Stuffit Expander and The Unarchiver for free. Those are just the ones I'm aware of.
If the zipped files are Mac compatible, any one of these should open them.


Hi Dan,

My mac does not have ant windows installed on it and the files i download are not .exe but in .dmg that means they are mac. But when i try to open it, it say it can't run in Dos mode. And thanks for the software you recommend, i will try and use it. Can you please post the link to the software. Thanks very much.

REgards Roy

do you have DOSbox on your mac? but that's irrelevant to the fix.

after you download a zip file, navigate to it in finder. right click on it, select 'get info'. 2/3 of the way down it says 'open with'. select the application you want to use (assuming you have it already installed). i'd recommned clicking 'change all' as well, so you don't have to do it for individual files.

I have already tried that.Is there any other way?


i think we need some more info. what hardware/operating system are you using? what's this computer used for? what do the zip/dmg files contain (don't need specifics, but just file types and stuff like that)? the advice we've given should cover any normal situation... since it's not working, we need to find out what makes your computer different.

Hi tje210

I am using a Mac OS X and the version is 10.6.6 Snow Leopard the processor is 2.26 GHz Intel Core 2 Duo. The Macbook is use for education purposes as our school instruct every students to purchase macbook. Occasionally, i will use it to play games and go facebook. The zip files contains an free firewall software download from the internet. If there are any information, you need just tell me.


hi dan ,

may i know the extension of the zip file ?
is it .zip or .dmg?

Hi santuoo7

I am the one who had a dos problem with my mac.
The file is both zip and dmg

Fun! Is it .dmg.zip, or .zip.dmg?

hi tje210

The file is zip.file or sometimes dmg files

some of the files i download from this link


Some software when i tried to open pop out text edit and give me rubbish words and at the top say that it can't open in dos mode

ok, we're getting closer. what is one in particular? ill try it myself.

incidentally, are you looking for a particular firewall? or just want to try different ones out?

a different firwall. i will download a few and see which one is better and use it.

tried a few, no problems there. i would just say, back up your important stuff and reinstall snow leopard. something silly is wrong, and it'll take way more of your time trying to figure it out than to just start fresh. i would back up using carbon copy cloner, so that you can see exactly what you had before.

fyi, the firewall i use it called 'WaterRoof'... it's kind of a lower-level firewall, not very GUI but good for what i use it for.

Thanks i will try since i had given you the link to the free firewall download. Is there any firewall at the website to recommend i will try and see whether i can use it

Hi tje210

I have started a new thread. it is called web browsers. Go there and give me your point of view.



Sorry, the question I was to ask was irrelevant. I hadn't read page 2 of the answers.

Hi ilaureano

Do you face the same problem also or you know how to off dos mode?


If you know how to off dos mode please tell me quickly as most of the zip files i download say it cab't be open in dos mode.

Sorry I didn't reply yet. I don't check my Yahoo mail often enough and just found all my DaniWeb emails in my Junk folder.

For what it's worth, the only firewall I'd trust is Apple's built in firewall.
I don't even use it as I've seen no need to do so.

Net Barrier X and Lil Snitch are the only ones on that site that I've heard of and read about. I have Lil Snitch on my Macbook but it can be very annoying watching all the activity and having to close it's window all the time. I'm sure there are settings for it somewhere, but as little as I use that machine, I just haven't checked into it further. It does what it says, and I don't recall reading anything bad about it.

I'd suggest trying Apple's firewall. If your Mac doesn't want to open something, there's usually a good reason. And if zipeg or the unarchiver can't open them, I wouldn't want to. Just do a search for those and you will find them.

I looked at a few others that I've never heard of on that site and many, if not most are old and meant for PPC Macs, not Intel Macs like you have. That's probably the reason they won't open.

Just my opinion. If you use facebook and don't have all your security and privacy settings at the hilt, Lil Snitch will drive you nuts from all the info being sent back and forth from their 3rd party apps and fan pages and all the other advertising crap they have on there. I'd imagine, and maybe I'm wrong, but any good firewall would nullify Facebook browsing. That Zuckerberg founder said himself that people need to get over the privacy issue. What a guy.

I also just checked the Site Advisor status of the site you linked to and from users, it's not good. Just because McAfee Site Advisor itself, says it's okay, doesn't mean it's so.

Hope this helps you.

Hi ilaureano

Do you face the same problem also or you know how to off dos mode?

I have seen the "Cannot swith to DOS mode", but it has always showed when I double clicked a UNIX binary (UNIX exe). As far as I know there's no way to switch off the "DOS mode", because it's interconstructed in Mac OS X. Instead what I did was to begin a Terminal session (Aplications -> Utilities) and run it from the prompt.

But if you're positive the file is a Mac OS X app, maybe the best way to go is reinstall Snow Leopard.

Reinstalling snow leopard would take a long time and that was the last option i am going to use. Thanks for thee tip Danarchy, You just have another thread being solved by you

Restart your commuter and hold the cammand button

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.