0

Hi guys,

A very annoying problem. Hope you can help, I will try to explain how this problem occured so that you have a better idea about whats wrong:

1. I am running XP-Pro with SP2, P4 2.66, 1GB RAM, 40Gb HDD.
2. One day out of the blue every time i selected to shut down XP(after it closed the desktop) a complete blue screen appeared quoting " A Problem has been detected and windows has been shut down to prevent damage to your computer........" and gave me a list of options I should try.
3. After i restarted the computer and sent the error reports to microsoft, microsoft advised me to install an update for InCD(part of Nero) and an updated driver for my Graphics card. After I installed these updates it has been shutting down fine.
4. However now when I go to device manager I see my CD-RW and my DVD rom(two seperate drives)has an exclamation mark next to it. The message it shows in properties is "Windows successfully loaded the device driver for this hardware but cannot find the hardware device. (Code 41)"
5. I have checked cable connections and they are all fine. BIOS recognises the drives, it shows up in POST as well. So I unistalled both the drives in Device Manager and i selected "scan for hardware changes". XP recognises both the drives but fails to install them.
6. Since then I have uninstalled Nero and InCD but this has made no difference.

I should add that I installed SP2 on September 5th and since then till this week my computer has been running fine. And I have not really played about with anything really serious that should suddenly make these changes. Any suggestions or ideas will be great help. My gut instinct is that it is a software issue rather than hardware issues(famous last words?).

4
Contributors
7
Replies
8
Views
12 Years
Discussion Span
Last Post by jmonroy1973
0

Follow the instructions to edit the registry in the following Microsoft Article # KB314060

0

Hi abbasmj,

Thanks a lot for that, it did sort it out. Just out of interest did you know of that article by previous experience or did you find it out yourself? I tried so many search options in Google and in Microsoft and couldn't find that article. Have you got any tips on how to search better for future problems?? All the best & thanx again........

Shib

0

Dear Shib_00

You are welcome. I had known this article through the experience. I also did a lot of search on this article. Microsoft took a bit of time in entering this information in the knowledgebase

0

I also get the same message. I have uninstalled my dvd-rw, run hardware intaller, windows finds my dvd-rw, installs the driver for it, and then it won't even show up under windows explorer. I see it in the device manager with an exclamation mark :!: indicating that windows has "installed the driver but cannot locate the device" what gives? :evil:

0

jmonroy, Hi and welcome.

Read the article I linked to in the post above. It leads to some more detailed discussion of this and similar problems, and how to resolve them.

If you have further problems afterwards, please start a new topic of your own. You should have a better idea of where your problems stem from by then.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.