Hey all! Again, it has been a while.

Anyway... I just replaced the battery on my laptop, and I've been having issues with the volume control icon in the taskbar tray. Every time I start the computer, it's not there. If I go to "Sounds and Audio Devices" in the control panel, the box that says "Place volume icon in taskbar" is always checked. I have to uncheck, apply, recheck, and hit okay in order to use the volume bar.

Now, this was just an annoyance until recently. I alluded to replacing my battery earlier... While my battery was unable to charge, it never struck me that my taskbar icon for the battery/power supply was never in the taskbar tray. However, now I find that I have an even worse issue than that of the sound icon: I can't get this icon to show up at all!

Also, I cannot get the LAN control icon to go away from the taskbar.

For some reason, Windoze decided to hate me this time around, and believe me, the feeling is now mutual.

Does Anyone have any suggestions for solving these problems?

Oh, and by the way, workarounds are fine, if there's a program I can use that'll output battery power/charging percentage on the desktop, or what have you, I might be able to deal with that, too. I'm working on getting the sound buttons on the computer's case to work now.

Okay... so now it would appear as though it only happens some of the time. Sometimes, my taskbar is fine, the hide button is there, all my icons are there, and the LAN goes away when I'm not using it, and the volume control and battery stay there. Was there a problem with HP OEM discs' taskbars? I googled the issue, and found little to nothing.
This was a fresh install of windows when it started doing this, too. I don't know what in the heck is up with it and I'd like to.

And sorry about the triple posting, I can't edit my own posts after a certain period of time, I guess. I guess if I don't receive any help on this one, I may as well document the issue here so someone else can fix their problem later on...

Alright, I found a solution to the problem.

This is an issue caused by the (albeit COMPLETELY UNRELATED) "UPnP User Interface" That was an optional component to the windows networking services package that comes on every computer. I can see why most people don't have this problem now, this isn't something many people enable. I thought it would be nice, but I guess not.

If you go into the "Add/Remove Programs" in the control panel, then goto "Add/Remove Windows Components", and click on "Networking Services" you'll find a button called "Details". In that box you can disable the "UPnP User Interface" and reboot the computer.

Problem Solved.