0

I have read all previous posts on this topic but the help provided did not work.

SVCHOST.EXE using 100% CPU

svchost.exe is using 100% cpu usage an making it hard to do anything.

I have reinstalled win xp that did not work.

I have formated the comp an that worked for a bit then it just starts doing it again.

At current i have 4 svchost running an 1 im not sure about is called scvhost.exe an system is using 40% of cpu.

i have 2200amd asus a7n8x deluxe mb 256 ddr

This only started when i got my new video card asus gf fx 5200.

Previously i have had the blaster virus if this helps but during that time an now i have done atleast 5 full formats due to frustration an my video card lagging.

Can someone help me out here plz with really detailed instrutions plz.

TY kojak


I have tried this answer an now i can actually end task svchost.exe but after like 2min it starts up again. Where as before if i were to close it my comp would shut down.

Click Start > Run. (The Run dialog box appears.)
Type:

SERVICES.MSC /S

in the open line, and then click OK. (The Services window opens.)

In the right pane, locate the Remote Procedure Call (RPC) service.
--------------------------------------------------------------------------------
CAUTION: A service named Remote Procedure Call (RPC) Locator exists. Do not confuse the two.
--------------------------------------------------------------------------------
Right-click the Remote Procedure Call (RPC) service, and then click Properties.
Click the Recovery tab.
Using the drop-down lists, change First failure, Second failure, and Subsequent failures to "Restart the Service."
Click Apply, and then click OK.

so not select " Restart the service".Just select " Take no action ".Press ctrl+alt+delete and click on processes.Then find out the svchost.exe that is 19800 kb in size and does not run for either " network" or " local service" but runs for "system".That should clear up.Well,it has worked for me i don't know about others...

Votes + Comments
In future please refrain from saying pissing
25
Contributors
29
Replies
32
Views
14 Years
Discussion Span
Last Post by MaxMayhem
0

Ok i fixed it.

I used a blast virus remover which didnt find anything but i applied the blaster patch an all is sweet now.

EDIT: i lie when i connected to the net it started up omg.

0

where is the blaster patch thing that fixed it cuz my blaster fix didnt find it either

0

well svchost only uses 100% cpu only when im connected to the net now instead of as soon as the comp boots up.

Just type blaster remover in google an then blaster patch in google. Microsoft.com an nortans website have them.

That link above go directly to the specified problem but ahwell ill keep looking for it.

If someone that has fixed this problem can you plz post direct links to instructions over even post them here plz.

0

I have had this problem on win xp and 2000 which is what i have now with the same problem, the closest thing i have found for a fix is a program called processxp from www.sysinternals.com that will show the child programs of svchost and u can close the one that shows high % but since u closed svchost some stuff doesnt work right i have noticed periodic internet activity problems and some other stuff acts funny.pretty funny as a matter of fact but its better than 100% cpu usage. Something i just tried but im not sure is going to work is with that program u can open the child svchost program and it shows all the threads and their cpu usage then close the high % ones there. That way svchost is still working but u stopped the problem thread, mine was a remote procedure call which sounds like blaster but ive tried all the removals and patches.(the threads popped up 1 more time after i closed em but they havent come back for a while now) its been working good for about 20 mins on the net now (which is when mine happens too, never offline).Ill let u know if it keeps working after a day or so. hope it helps you.

I have had this problem for ever and it is very annoying and i think i might have finally fixed it, of course ive thought that about 20 times

0

Well it sort of works, all the basic stuff works and internet, but when i try to play a game online for some reason every 5-10 mins it lags out for a minute or so

0

Well it sort of works, all the basic stuff works and internet, but when i try to play a game online for some reason every 5-10 mins it lags out for a minute or so

I have been reading all day about the SVCHOST issue where folks are experiencing 100% cpu activity for a while as soon as connecting to the internet. My fix is limited to the situation outlined below and does not include the 60 second shutdown issue or crashing.


Some websites and forums suggested that SVCHOST is being exploited by a worm or trojan, but most people find their virus scans come up empty as do the spyware checkers. So your computer is mostly OK except for this cpu drain that seems to last only a short time.

I have had the problem for about a week and I have tried five different virus scans (including on line McAfee, AVG, PC Security Shield, and Symantec) and two spyware programs (Adaware and Xoftspy) but found nothing of import. My "Hijack This" log has not changed. It started after a recent Microsoft Automatic Update to my Windows XP SP2 system. So if you dont have a virus, and still have this problem, here's what I did.

Using Process Explorer (from SisInternals --
http://www.sysinternals.com/Utilities/ProcessExplorer.html
I could see that one of the many SVCHOST copies was running (1144) which was attempting to assist Microsoft Automatic Updates (3108 and 2720). My Automatic Updates was set for "Notify Me but do not download or install". Apparently the cpu usage is caused by the Updates program attempting to determine if there are updates which it of course only does when you connect to the internet. I simply set my Automatic Updates to OFF and the problem disappeared. I did not experiment with allowing it to be ON full automatic mode, but I suspect that would be OK too. Appears to me that Windows is not playing nice with the Notify me but do not download option.

Wanted to let you know cuz lots of folks are suffering. I suspect this is something MS will be fixing in a future update.... When you start your machine, immediately start the Process Explorer, and watch the cpu usage as your internet connection is established. If you see that the SVCHOST that is causing the CPU load has underneath it (below the minus sign associated with it) one or two Automatic Update listings, then try my fix by either shutting off Automatic Updates in Control Panel (Automatic Updates).
Regards, Dan

0

MS has finally fixed ALL the bugs relating to SVCHOST. The patch can be found at:

http://support.microsoft.com/default.aspx?scid=kb;EN-US;Q927891

It's an update to the same patch released a month before, which actually didn't work for me. After installing this new patch it's fixed this problem which I've been having for a year now and has prevented me from using Microsoft Update and would randomly lockup up the PC about 3 times a day!

0

For those of you who have svchost.exe using 100% CPU, I used to be one of you. I found out what the problem was. The first thing I did was download Process Explorer from here: http://www.microsoft.com/technet/sysinternals/utilities/ProcessExplorer.mspx It look up svchost.exe and found out wuauclt.exe (Automatic Updates) was consuming most of the CPU. After realizing that Automatic Update was the source of all the trouble, I went to Control Panel > Security Center, then I scroll down to find Manage security settings for: then click Automatic Updates. Finally click Turn off Automatic Updates then OK and my trouble was gone. My CPU usage drop the second I disable Automatic Updates and my computer was fast and usable again. You should try this, it work for me and maybe for you!

0

Hi, I had this problem also and I think I found the fix on another site. It seems to work for me. It is an issue with Auto Update.

Go here and look down the page for a post from pati610.

http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=906329&SiteID=2

Hi

I have had this problem on a couple of machines.

The following worked on both occasions.

Right click on my computer- expand Services and applications – click on services – Right click on automatic updates – Properties – select disabled as the startup type. Reboot , navigate to C:\windows\ rename the folder SoftwareDistribution to SoftwareDistribution.old
Go back to services and set the startup type to automatic.
Reboot – failed updates should now install and CPU usage drop to normal level.

0

Hi

I have had this problem on a couple of machines.

The following worked on both occasions.

Right click on my computer- expand Services and applications – click on services – Right click on automatic updates – Properties – select disabled as the startup type. Reboot , navigate to C:\windows\ rename the folder SoftwareDistribution to SoftwareDistribution.old
Go back to services and set the startup type to automatic.
Reboot – failed updates should now install and CPU usage drop to normal level.

Hi,

I tried this fix and cannot rename the folder, due to an access denied message. I tried by right clicking and selecting rename. I also tried changing the attributes to eliminate the read only. Why doesn't it work?

0

Hi, the folder cannot be renamed if it is in use. It is usually in use by the Autoupdate service that is why you have to temporarily disable this service and then reboot. Once the machine has restarted you will be able to rename the folder.

Remember to set the service back to start automatically when you are done.

0

I'm an A+ certified PC Technician and have run into this problem countless times and seem to have started since the release of Microsoft Update. Microsoft Update combines both Windows and Office Updates together. The result is 100% CPU utilization for prolonged periods. If you're not doing anything and the CPU is 100% or you hear your CPU fan kick in like an airplane taxing down the runway at takeoff, chances are good that Automatic Update is checking for Windows/Office Updates. Microsoft has a "hotfix" that claims to fix this but it's not publicly available for download and prompts you to call Microsoft to get it. Well, I did call Microsoft and it was like pulling teeth to get it. The 3 different technicians I spoke to cite other local factors, like malware (virus, trojan horse, adware, spyware, etc) or other CPU intensive programs running at startup. With a little more force and less patience, I asked to skip the troubleshooting and go right to the hotfix. Surprisingly, none of the Microsoft technicians were able to get to it and kept transferring me to someone else in India (OK, OK, maybe it was Bangladesh) who gave me the same answer. After a lot of head scratching, I was finally E-mailed the "hotfix" but it was password protected, and only good for two weeks. So, basically useless for helping others out over a long period of time. To my surprise, the fix was actually a patch for the hotfix, so it did absolutely no good without having the original fix. I gave up trying to make Microsoft Update work. Here's the manual fix:

The first step may not apply if you don't have Microsoft Update installed:
Go to Windows Update.
On the left side, click the link "Change settings".
Check the box "Disable Microsoft Update software and let me use Windows Update only".
Click "Apply changes now".

Now, onto the slightly technical part:
Right click My Computer and click Manage.
Click the + next to Services and Applications.
Click Services.
Right click Automatic Update and choose Stop. Keep this window open, as you'll need to come back for the last step.
Open up Windows Explorer and browse to %WinDir%\SoftwareDistribution\DataStore. Note: %WinDir% is usually C:\Windows or C:\WinNT
Delete the contents of DataStore.
Lastly, go back to the Computer management window and right click Automatic Update and choose Start.
No reboots are necessary and I'd be very surprised if this doesn't fix the issue with SVCHost.exe running 100% CPU time.

Theory:
Using Process XP (a souped up Task Manager browsing Processes) shows that when CPU utilization is 100% that SVCHost.exe is married to @ 2 DOZEN different services. I can't think of any reason why one single process should have that much association with other services. Most processes link to at most 1/2 dozen services. It's no doubt that CPU's are busy with that much linked association. I truly hope Microsoft identifies and repairs the code to their Microsoft Update. I now have to remember to manually run Office Updates separately. Good luck to you all.

For more information: http://support.microsoft.com/kb/916089

0

Alright guys. here is the fix.

http://swigartconsulting.blogs.com/tech_blender/2006/07/windows_update_.html

I have read all previous posts on this topic but the help provided did not work.

SVCHOST.EXE using 100% CPU

svchost.exe is using 100% cpu usage an making it hard to do anything.

I have reinstalled win xp that did not work.

I have formated the comp an that worked for a bit then it just starts doing it again.

At current i have 4 svchost running an 1 im not sure about is called scvhost.exe an system is using 40% of cpu.

i have 2200amd asus a7n8x deluxe mb 256 ddr

This only started when i got my new video card asus gf fx 5200.

Previously i have had the blaster virus if this helps but during that time an now i have done atleast 5 full formats due to frustration an my video card lagging.

Can someone help me out here plz with really detailed instrutions plz.

TY kojak


I have tried this answer an now i can actually end task svchost.exe but after like 2min it starts up again. Where as before if i were to close it my comp would shut down.

Click Start > Run. (The Run dialog box appears.)
Type:

SERVICES.MSC /S

in the open line, and then click OK. (The Services window opens.)

In the right pane, locate the Remote Procedure Call (RPC) service.
--------------------------------------------------------------------------------
CAUTION: A service named Remote Procedure Call (RPC) Locator exists. Do not confuse the two.
--------------------------------------------------------------------------------
Right-click the Remote Procedure Call (RPC) service, and then click Properties.
Click the Recovery tab.
Using the drop-down lists, change First failure, Second failure, and Subsequent failures to "Restart the Service."
Click Apply, and then click OK.

so not select " Restart the service".Just select " Take no action ".Press ctrl+alt+delete and click on processes.Then find out the svchost.exe that is 19800 kb in size and does not run for either " network" or " local service" but runs for "system".That should clear up.Well,it has worked for me i don't know about others...

0

I applied the patch listed above (which had a 5/7/2007 date on it). I turned automtatic updates back on and things seemed great for a few minutes (previously it took only about 2 minutes to lock up), but then 100% cpu usage for svchost again. So I'm back to no automatic updates and still looking for a permanent solution. Thanks so much for getting me on the right track with the automatic updates. At least I can use the machine!

0

Hello, I am posting this here because of this site's high google pagerank.

The workaround for this:

Disable windows update service by going to Control Panel > Administrative Tools > Services and stopping the “Automatic Updates” service. Set it to disabled for now.

This will stop the freezing issue.

The fix for the windows update svchost.exe error is this:
1. Install the new windows update client:
WindowsUpdateAgent30-x86.exe
http://download.windowsupdate.com/v7/windowsupdate/redist/standalone/WindowsUpdateAgent30-x86.exe

2. Install hotfix KB927891
http://www.microsoft.com/downloads/details.aspx?FamilyId=7A81B0CD-A0B9-497E-8A89-404327772E5A

0

Hello there everone. This svchot.exe issuegave me problems for weeks but I found the solution. I tried everthing in the suggestions on here with no luck. There was one thing that fixed it and one thing only. My computer has been working fine for ages now with reboots, loads put on the system etc etc.
You need to go to this website, http://www.spywarebot.com/ , in safe mode and download this application "SpywareBot". It will cost you $19.95 but it is a better solution than stuffing around for weeks on end trying to fix the issue with no success as I found out. It is a brilliant program and I highly reccommend it.
Goodluck!!!

Spudman1979

0

This sounds like the Blaster Worm virus. Since you have reinstalled Windows XP have you upgraded your Service Pack to SP2?
Might want to run your updates.

Next make sure your powersupply can handle your video card. Check the needed wattage for your PS unit vrs. your new Video card.

Finally if all checks out and it is still using 100%. Start removing some of your startup files in MS config.

RueB 2s De

0

Travis,
Just wondering if you or anyone as applied this patch to Win2K Pro? The MS web site says this is only for Xp and 2003 Server. I am having the scvhost.exe problem with Updater as well.

Thanks

0

I'm an A+ certified PC Technician and have run into this problem countless times and seem to have started since the release of Microsoft Update. Microsoft Update combines both Windows and Office Updates together. The result is 100% CPU utilization for prolonged periods. If you're not doing anything and the CPU is 100% or you hear your CPU fan kick in like an airplane taxing down the runway at takeoff, chances are good that Automatic Update is checking for Windows/Office Updates. Microsoft has a "hotfix" that claims to fix this but it's not publicly available for download and prompts you to call Microsoft to get it. Well, I did call Microsoft and it was like pulling teeth to get it. The 3 different technicians I spoke to cite other local factors, like malware (virus, trojan horse, adware, spyware, etc) or other CPU intensive programs running at startup. With a little more force and less patience, I asked to skip the troubleshooting and go right to the hotfix. Surprisingly, none of the Microsoft technicians were able to get to it and kept transferring me to someone else in India (OK, OK, maybe it was Bangladesh) who gave me the same answer. After a lot of head scratching, I was finally E-mailed the "hotfix" but it was password protected, and only good for two weeks. So, basically useless for helping others out over a long period of time. To my surprise, the fix was actually a patch for the hotfix, so it did absolutely no good without having the original fix. I gave up trying to make Microsoft Update work. Here's the manual fix:

The first step may not apply if you don't have Microsoft Update installed:
Go to Windows Update.
On the left side, click the link "Change settings".
Check the box "Disable Microsoft Update software and let me use Windows Update only".
Click "Apply changes now".

Now, onto the slightly technical part:
Right click My Computer and click Manage.
Click the + next to Services and Applications.
Click Services.
Right click Automatic Update and choose Stop. Keep this window open, as you'll need to come back for the last step.
Open up Windows Explorer and browse to %WinDir%\SoftwareDistribution\DataStore. Note: %WinDir% is usually C:\Windows or C:\WinNT
Delete the contents of DataStore.
Lastly, go back to the Computer management window and right click Automatic Update and choose Start.
No reboots are necessary and I'd be very surprised if this doesn't fix the issue with SVCHost.exe running 100% CPU time.

Theory:
Using Process XP (a souped up Task Manager browsing Processes) shows that when CPU utilization is 100% that SVCHost.exe is married to @ 2 DOZEN different services. I can't think of any reason why one single process should have that much association with other services. Most processes link to at most 1/2 dozen services. It's no doubt that CPU's are busy with that much linked association. I truly hope Microsoft identifies and repairs the code to their Microsoft Update. I now have to remember to manually run Office Updates separately. Good luck to you all.

For more information: http://support.microsoft.com/kb/916089

Thankyou!! I have been looking for a fix for this for months and nothing has worked up until now. I'm sure everyone in this thread knows the stress and frustration that the problem can cause and I'm glad it's over now. thanks again.

0

i have 927891 installed butstill have the issue.(btw, anyone know a quick way to id what updates are installed without having to scan thru the add/rmv pgm in control panel? like, export list somehow and do a find in excel or something???)
this situation started when i installed DSL. i have used process explorer but all it does is confirm svchost is at 100% and shows about 30 services running. canning each one didn't provide any relief and had to restart machine to get things runnng again.
the 100% cpu use seems to occur once i come out of sleep mode, i don't even have to try to get to internet; it seems to be trying to set networking or connectionsor something but i don't know how to tell what. i tried turnin off modem, lan, etc to avoid it but that didn't help.
the situation continues. i don'thik ms has fixed this and would appreciate any hints on how to nail down what is causing it and how to get around it without having to shut down/restart every time. hope this helps us get to a better resolution than what i've seen posted around so far.

0

for what it's worth:
i have turned off the power option to suspend the machine after 30 minutes and set up a blank screensaver after 20 minutes. i haven't had the cpu spike to 100% since making that change.
the 100% cpu spike seems to be related to whatever the machine is doing with svchost.exe as it comes out of suspense mode.
does anyone have facts on the impact of using blank screen saver instead of going into suspend mode? i turn the harddrives off after 15 minutes of non use.

0

I fixed my “svchost.exe problem”!
I’m running XP Pro 5.1.26 SP2 on an AMD 2.393 Mhz processor and 2GB of memory
I tried the fixes on Microsoft’s site, ran half a dozen Registry Repair softwares, and shut down various applications, all without effect.
I got rid of the “svchost.exe” problem by shutting down svchost-related services one-at-a-time until I saw the CPU break free from the 99% level at the top of the moving graph in the Windows Task Manager. Its a time-consuming, but systematic process reported below.

1. CTL-ALT-DEL to open Windows Task Manager
2. “Performance” tab to confirm CPU usage is maxed out
3. “Processes” tab (click “cpu” column headder to rearrange in order of CUP use)
4. If “svchost.exe” shows as 99, leave WTM open on this tab
5. Go to “Start” “run” and type “services.msc” into the window and “enter”
6. Click on the “status” column head to rearrange “started” services together at top
7. Prtscrn or screencapture the list of services so you can check them off as you test each service.
8. Double click on each service to open a “Properties” window
9. Most likely you’ll see in the “Path” window (for at least some of the services) something like “C:\windows\system32\ svchost.exe’ followed by a space, -k and a descriptor
10. Click on the radio button below “Stop” and watch what happens to the CPU number back in the Windows Task Manager (it sits on top on my machine).
11. When you get the right Service, you’ll see the CUP usage drop almost immediately.
12. Hit the “Performance” tab on the WTM and confirm that your CPU has been liberated.
13. Go back to the “Services” window for the problem executable and change the “Startup type” to “Disable”.
14. Reboot to confirm you haven’t disabled some vital service.
15. In my case the problem executable was “HP Network Devices Support”.
16. Advice: Keep notes on the Services prtscrn so you can back out if something goes awry. I’m no IT maven and don’t know enough to say it will work without adverse consequences every time; but it worked for me and survived reboots and other changes.

0

What I have found is that removing all versions of Java prior to Java 6. If java is not installed, go to java dot com, and run the installer. SVCHOSTS drops to a normal rate, windows update responds in normal time, and allis back to normal. :) Good luck!

0

svchost.exe is like a ghost in my machine, is doesn't stop, it's not a virus, it's evil. I've download all the updates; (WinUpdAgnt30, WinXP-kb927891.exe, fix_svchost.bat) it does not work. Tried the "services.cpl", changed to *HP Network Device Support setting from automatic to manual, didn't work. *Heard this from other sources.......

0

I tried all the tips ppl have posted here, but none worked for me. The one fix that seems to have worked was as follows:

Using Process Explorer
http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx

I could see which svchost was the issue.
Then I right clicked on offending process & went to properties.
Then click on the threads tab
There you should see the thread causing the problem.
Highlight it and kill the thread.

Havent yet rebooted to see if I need to do it every reboot, but my cpu usage is normal again. :)

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.