0

Hi has anyone found a solution to sharepoint word documents opening in read only mode ; even when you select edit in word form the drop down menu? we are running sharepoint on windows xp sp2 with office 2003. This has only just started to happen the past few weeks nothing seems to have changed on the pc no auto updates or anything like that.

2
Contributors
2
Replies
3
Views
8 Years
Discussion Span
Last Post by Wooly
0

UPDATE: some people notified me about this not working for SharePoint. Too bad, I didn't test and read it well. Sorry for that!

Something which is hard to explain to customers is why they can edit a document in SharePoint only via the document context menu 'Edit in Word' and not directly via the link to the document. Especially when a link is provided in an email message, it is annoying to see that you can only open a document in read only mode.

Today I got the question if it was possible to create a list of links directly to documents to edit, without opening them in read-only mode. Good question, good reason to find a solution!

The behavior is managed client sided. SharePoint uses javascript to open a document in edit mode. It looks something like this:

javascript:editDocumentWithProgID2(/'path/document.doc','Word.Document','SharePoint.OpenDocuments');

The problem with this is that regular SharePoint users cannot link to the document directly and it is not really user friendly.

During my search I ran into a MS KB article that explained that you can change the behavior of opening document while browsing in the registry. The steps to take:

1. Quit all Office 2003 and 2007 Office programs that are running.
2. Click Start, click Run, type regedit in the Open box, and then click OK.
3. Locate and then right-click the following registry subkey: HKEY_CURRENT_USER\Software\Microsoft\Office\<version_number>\Common\Internet
4. Point to New, and then click DWORD Value.
5. Type OpenDocumentsReadWriteWhileBrowsing, and then press ENTER.
6. Right-click OpenDocumentsReadWriteWhileBrowsing, and then click Modify.
7. In the Value data box, type 1, and then click OK.
8. In the File menu, click Exit to quit Registry Editor.

For more information about this check out the KB article.

0

Thanks for answering I had tried that already just in case but with no such luck - its most annoying I am having to re-image laptops which is a bit extreme for such a stupid problem.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.