0

Hi All,

I am running Windows Vista and have a problem installing programs and windows updates.
It seems that the windows installer service is stopped and I can't get it to start. When I try to start it, it seems to start briefly and stop immediately.
Can anyone out there shed any light on this for me?
Thanks

6
Contributors
18
Replies
21
Views
8 Years
Discussion Span
Last Post by rmazzeo
0

Hi to both Ancient Dragon and Adamsappleone, thanks for your responses.

Yes, I am running both AV and Antispyware programs.

I get various messages depending on what I am trying to run. Some relate to registry entries missing, other say they cannot access windows services etc etc

0

Thanks Adamsappleone.
Unfortunately, the articles you refer to are XP related. I have tried the Vista equivalents but still have the problem.

0

so you have downloaded the latest windows installer for vista , and you set it to manual and hit start ,in services ,and still get errors ,correct

0

I've got Windows Installer 4.5
When I double click on it in services, I get the following error message:
"Configuration Manager: A required entry in the registry is missing or an attempt to write to the registry failed."
When I OK that message, the Installer Properties box opens (normally?) showing the service status as stopped.
When I click on start, it starts and within a second stops with the following message: "The Windows Installer service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs."

0

Was you logged in as an Administrator when it was first installed? You may have to uninstall it then download and reinstall it again.

0

Yes, installed as administrator.
The problem started when I could not install updates. Since then, I found that I can neither install nor uninstall programs. So uninstalling and reinstalling Windows Installer is not an option.

0

I had a similar problem when I tried to install Windows 95, SP1. The sp1 install failed but could not uninstall 95. I finally found a work-around by reinstalling 95 from original CD, then Control Panel would let me uninstall it.

0

I haven't got a Vista disc - came OEM preloaded with recovery disc.
I'm trying to avoid having to run recovery...

0

Thanks Adamsappleone for your help.
Having tried various ways to solve this problem, I have given up and gone the restore route. Ahh well....

0

Had this with XP before (Back when Windows Installer 3.1 came out). Used dial-a-fix to reregister the WI dlls and service. Dont think such an app exists for vista though.

0

This is not a reply, per se. It is a question on the same subject, but since no one has come up with an answer, I thought I'd try to reopen the discussion. Problem: HP Pavilion dv7 running Windows 7 Home Premium 32-bit. Windows Installer is stopped & will not start. I have searched & tried everything I've come across on the internet, unregistering/re-registering, making registry changes, forcing uninstall of certain programs, all to no avail. This is a client machine & he needs it back, but I can't fix it unless I get the installer working. Windows 7 runs Installer v5, which is not available as a redistributable, nor would that work anyway, as it has to be installed as well. The only thing I haven't tried is using Installer v4.5 to replace the current & then upgrading, but I really don't want to completely hose this client's PC. Any ideas?

0

There is a tool called dial-a-fix that I've used to fix windows installer before under XP. Don't know if it works in 7.

0

these are just thoughts , have you booted to win7 dvd and run the repair ,have you trie System file checker , "sfc /scannow" in run or cmd

0

There is a tool called dial-a-fix that I've used to fix windows installer before under XP. Don't know if it works in 7.

This tool was only good until Windows XP. It is not made to be compatible with Windows Vista or Win 7. Thanks anyway. Everything else I've tried does not work. I have come to the conclusion that my client's PC is so badly hosed that I have to do a complete restore.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.