I've posted this on another forum but didn't solve the problem, so I thought I would try here :)

I have an Acer Aspire X1200 with 4 gb ram, Athlon 64 dual core 5000+ 2.6 gh, and am running Vista Home Premium with SP2. I've had it about a year with no problems, although it's a refurb.

My problem is when I start up (which starts up normally and fast), the PC slows down to a crawl. I seem to have a few minutes where it will work normally, and then it slows down. I have a CPU gadget in my sidebar and it shows the usage goes down to 0%-2% no matter what I do. If I click on the start button to go into control panel, it sometimes takes 5-10 minutes before control panel will launch or before I can even click on it to launch. Eventually the PC seems to freeze up, but sometimes I can run something (e.g. spyware search and destroy) and if I leave it, it will do a full scan. I'm not positive the PC actually freezes because after 30 minutes of waiting for things, I get impatient and restart. I have the same problems more or less in Safe Mode. :'(

Last week I had a windows update sitting in my systray. It had installed but was waiting for reboot. I kept postponing it, and clicked on it to postpone again, and my PC completely froze up. I rebooted and it froze after about 5 minutes. This happened every time I rebooted. Before it froze, there was an error which read: Error Line:1 Pos:1 An invalid character was found in text content. There was no indication which program this belonged to though!

I have since uninstalled the windows updates, in case they caused the problem, but it doesn't seem to have helped. The updates were KB977165 (which appears to be problematic for XP users), and an Nvidial Display GeForce 9200 update, and an Nvidia Nforce NEtworking Controller update.

I managed to scan my PC for spyware and it found a few cookies which were removed. I regularly scan for viruses, but did a full scan anyway and it found nothing (I use Bitdefender antivirus).

When this first happened, I tried to do a system restore, but ALL of my restore points were GONE! I have made some manual restore points since, and a few (not all!) are still there, but I cannot restore them. When I tried system restore through safe mode with command prompt I got the error: rstrui.exe application error. The instruction at 0xfe312046 referenced memory at 0xffffffff. Memory could not be read. I received this error each time I tried. When I tried through regular safe mode, the page that says system restore is initializing sat for about 15 minutes, then my PC rebooted and said windows recovered from a serious error. It asked if i wanted to check for a solution. I clicked YES, but nothing happened... and then the system froze again.

I've had another error page saying Windows has had a serious error, and it recommends that I disable caching or shadowing in the bios. I haven't tried this and I'm a bit leery about touching the bios without an expert telling me to do it.

I can last a few minutes longer in Safe Mode, but it freezes/hangs there too. I'm not really sure if it conks out completely though. In normal and in safe mode, if I click on (for example) the Start button, I get the hourglass, 4-5 minutes later the menu comes up. I can click on an item and may have to wait another 5 minutes for it to launch the item (e.g. control panel).

I thought I had fixed the problem on Saturday but I'm not sure what I did -- I may have reinstalled the NVidia display driver or something similar.

I've also noticed a LOT of wmi errors in the log.

It was working "ok" since Saturday, but lagging a little (10% maybe), especially with video (watching an AVI file, using a webcam). I've tried running it on 16bit colour, which helps a little, but when I move a window (e.g. an msn chat window) to another part of the screen, it leaves bits behind. My monitor is fairly new (Dell 2408WFP) and I've never had any video problems with it before.

I thought I'd try rolling back the NVidia display driver windows update on Monday and that's when my problems started ALL over again! After a few hours, I went in through safe mode, deleted the driver and let Windows find a new one. Same problem though.

I haven't installed any new devices or software this year. I've unplugged all USB devices other than my keyboard and mouse. I've run the Vista memory check and my memory passed. I've done a chkdsk and it fixed a lot of errors (some orphaned files). I've opened the PC up and cleaned the fan, checked for dust, (though it wasn't too bad - I had cleaned it in December). I removed one stick of ram and still had the same problem.

I hope the above makes sense. Does anyone know what I should try next? I don't know if this is hardware, software, or ?? I dont know if I can trust the vista RAM test, but it's a bit difficult accessing the second stick of RAM in this PC as it's a mini tower.I suppose I can restore to factory default but it would take soooo long to reinstall all my apps, and I'd be really upset if that didn't fix my problem.

I tried the repair option. It found no problems and system restore won't work. I ran the sfc /scannow and at the end it said there were corrupt files but they were not able to be fixed. I checked the log and the errors were pertaining to settings.ini and the sidebar. A google search led me to a Microsoft article saying this is a false report and to ignore it. I've disabled the Windows sidebar anyway, just in case. I also checked the event logger and found two errors that stood out more than the others:

Diagnostics performance - Event ID 402. Critical error. This process is doing excessive disk activities and i impacting Windows Performance. \Device\HardDiskVolume2\Windows\System32\svchost.exe

Op Code (655 3600) Code integrity warning
Code integrity was unable to run the \systemroot\system32\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\Lvpr2m64.cat catalogue
--- This error showed up over 100 times and went back a few months or so ---

I've tried to install malwarebytes but get this error: vbalsgrid6.osx not correctly registered. File missing or invalid.

If anyone has ANY ideas, please throw them at me... I appreciate any help you can give me! I'd especially like to know if this sounds like it could be a hardware or a software issue.

Thanks in advance and sorry for the extra long post. :)


Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.