My hard drive has just started asking me to load a disk and that as far as I can get - any suggestions??

Hello,

Could you give a little more detail please?

eg, when does this message come up, when did it start to happen etc..

Hi Xlphos,

I left this drive switched off for several weeks, when I fired it up again it asked me to 'Please insert a disk in drive E:.

I tried changing USB port and also the USB cable. I dicconected the drive and tried again - no luck.

I also tried changing the Drive letter with no effect.

The only things that have happend since I last used this drive are:

I removed another Lacie hard drive which had ceased to power up.

I connected a new Seagate portable drive - which worked fine even when I used the same port as the 'offending' drive.

Thanks for your interest

Cheers

McCads

Perhaps it wants to load the LaCie drivers?

Perhaps it wants to load the LaCie drivers?

Thanks Gerbil, downloaded and installed the latest driver - it did not solve the problem
Cheers

McCads

Okay... let's see... Windows does not know your drive by its drive letter, that is just a tag it applies to simplify things for us.. ["I also tried changing the Drive letter with no effect."].
HKLM/System/MountedDevices.

"The MountedDevices subkey stores the database of mounted devices for the NTFS file system. This database associates persistent volume names with unique internal indentifiers [guid] for volumes. The internal identifiers often include the disk signatures of the volumes. This pairing enables NTFS to maintain the identity and persistent name of a volume, even when its variable device name changes.
NTFS uses this subkey to support mounted drives on all types of volumes, including removable drives and CD-ROM drives."-M$.

The \??\Volume{... entry is the volume name; double-click an entry, a window should pop with text representing that drive's guid.
eg. \??\STORAGE#RemovableMedia#7&23909c82&0&RM#{and remainder}
The \DosDevices\... entry relates the volume name via that same guid to the drive letter associated with it currently.
eg. \DosDevices\K:
Windows keeps track of all removable storage-devices ever connected. So the moment you connect e.g. a USB-storage-device a new entry will be added to the list. The reason for this is that you're able to access a specific storage-device even if the drive-letter changes or if it even has no drive-letter assigned. The Logical Volume Manager of Windows uses this to show you a list of available devices, even the ones that have no drive letter assigned. If you change the partitioning of a device then it is given a new volume name.
So...:) in case there is confusion identifying your drive you could note your device at \Dos Devices\"its drive letter": and next associate it with its \??\Volume {....} entry. [to find which one you will have to dclick on each, read the upper part of the ASCII interpretation to identify the drive] until you find the correct one... then delete both entries.
Restart your machine, the drive should be re-associated.
Or simply delete the whole MountedDevices key and restart; it will be recreated with new volume names for all currently connected drives.

Hi Gerbil,

Thanks again for your advice - Your reply is way above my skill level - I have a friend who may be on your wave length - I will let you know the results.

Cheers

Mccads

If you wished to do what i suggest in the last line of that post, then just copy the text in the box to a notepad [format/wordwrap unchecked] and save as fixMD.bat to your desktop; dclick it to run... It will first export that key to your desktop for your peace of mind. :)

reg export "HKLM\System\MountedDevices" "%userprofile%\desktop\MounDev.reg"
reg delete "HKLM\System\MountedDevices" /f
pause

Then just restart. And to import that same file to the registry for whatever reason just rdlick it on your desktop, choose Merge [or Open with, Registry editor.... if you see that instead]. But importing it will revert your registry, so if the LaCie works after the restart importing it would set you back.
Amaze your techie friend.