0

What is this elusive file that keeps me from downloading IE8...or other things. 5Days ago I had the "Black Screen with Cursor" CURSE...It took a lot of work and research to get my system back, but this "ShRegGetvaluew" entry point missing from shlwapi.dll file, keeps popping up and stops any download....I've been reading about Many People having this problem...does anyone HERE have any Idea what to do?...PLEASE HELP!...captphrank

2
Contributors
10
Replies
11
Views
7 Years
Discussion Span
Last Post by gerbil
0

The problem lies with shlwapi.dll. It being a protected file you could try locating it in system32, change its name to shlwapi.dll.old. Within a few seconds WFP should copy in a new file from its cache. If this does not work, go Start, and enter in the Run space:
sfc /scannow
You may need your installation cd.
[you will not be able to delete the renamed file until windows stops using it in prefeence to the new file... say, after a restart...]

Edited by gerbil: n/a

0

Thank You Gerbil...I tried that already. I renamed shlwapi.dll to shlwapi1.dll and replaced it with one from a working computer. It didn't keep the message,from sowing up, shRegGetvaluew could not find entry point...Etc...I manged to get most of my system back with Wi-Fi and was on the net all day downloading upgrades from Microsoft. After I finished, Microsoft asked to 'Restart" computer to take effect. I re-started and ..a blue screen now shows saying "STOP: coooo221[Bad Image Checksum] The image SHLWAPI.dll is possibly corrupt. The header cecksum does not match the computed checksum....Can't believe it. I've been on the internet all day and saved evrything to a Restore point, but don't know how to get to the restore without Safe mode, or Go to last good known ...Neither is working...Oh Bother...captphrank

0

If you have SP3 then the most recent version of shlwapi.dll came with KB975713, and should be sprinkled liberally, in system32, $hf_mig$, Servicepackfiles\i386.
If you renamed it, and upon doing a refresh there was not a new copy there, then you do not have it in cache [which for SP3 is servicepackfile\i386]. WFP = Windows File Protection System.
Because your sys is no longer booting you will have to use the Recovey Console to copy it in from one of those locations. A bad shlwapi.dll will pretty much shut your system down.

Edited by gerbil: n/a

0

Whoops... dunno what I was thinking here: "then you do not have it in cache [which for SP3 is servicepackfile\i386]"
The cache will be, in this case, simply because it exists, the relevant folder in $hf_mig$. Because it is the most recent version, from a KB release.

Edited by gerbil: n/a

0

I tried the iso CD...it didn't work...as for the SP3... Ididn't even have SP1. I couldn't download 1,2, or 3 because the Shlwapi file won't allow it...catch 22...If I bought a new Hard Drive would I still have the problem?....

0

I know those isos are good _ I have burnt them, still have a cd of the first. Persist with it; burn it to a re-usabel. Make sure you burn the iso disk image itself, do not open it and try to burn the contents. For example, Nero has a quickstart option for burning a disk image.
A naked XP? Gee.... I didn't get to use anything earlier than SP2, so I am not sure where XP-naked caches shlwapi.dll. No matter, it is available for download everywhere, and will be backwards compatible. Sure to be... And your sys is not caching it anywhere, because you renamed it and a replacement did not pop.
Your problem is not hardware-based, the file in question deals with software.

Edited by gerbil: n/a

0

thanks again Gerbil...I did get to the Rec. Conole, but it was late and went to bed. once I got there I didn't know what to write in the Dos Promt. it just showed C: waiting for me to write something. I don't know much Dos...

0

Sleep is important.
Ok, you have to find a shlwapi.dll file to copy...
- forget finding one in your sys.
- use the free download on this page: http://dll.downloadatoz.com/shlwapi.dll-file.html -all you need do is dl it and use RC to copy it into your sys from some medium, a floppy . You will be restarting your sys so don't worry about the regsvr command.
- else, and easiest, copy it from the sys you are using now to a flashdrive or floppy... it is in system32.
Then, using RC, enter these commands:
map [this will give you the drive letter of your removable medium].
copy a:\shlwapi.dll c:\windows\system32 [for a floppy; change a: to whatever map gives you for the medium you are using].
Start your sys. Crossing fingers sometimes helps here.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.