0

Hello,

I run chkdsk once in a while and some times I get this message
Deleting corrupt attribute record (128, "")
from file record segment 286.

(The file record segment is random though)

This only started to happen after a power outage-- my computer blue screened and wouldn't start. I ran the Recovery Console form the Windows Xp cd and It booted again. However, I seem to have lost about 2GB of space too!. It is a 15GB hard drive with an NTFS file system but Windows only sees 13.9GB!

What can I do to correct this?

Thanks!

4
Contributors
19
Replies
22
Views
6 Years
Discussion Span
Last Post by javanoob101
0

The data has become corrupted on the hard drive. The only way that I know of to recover the missing hard drive space is to give it a full format. The problem with doing that is that you will loose all data and will have to do a fresh windows install!

0

Well Rik,you are correct!

After hours of "googleing" the issue I have come to the sad fact that I must reformat!

I'll hold out on formatting for now until I get the chance to format.

Thank-you Rik from RCE for your reply!

0

No problem. It's a shame there doesn't seem to be a way to repair your problem, I too did some googling!

0

I'm idly wondering if recently your MFT has not grabbed another 12.5% from the MFT Zone. Your drive is only 15GB; Windows and the few basic services, file systems and windows apps that I cannot move out of my C: occupy 23,000+ files on my 8GB system partition. The C: MFT is 75% full. So if the C: is your only drive with apps and data then perhaps your MFT has incremented in size. What does the Defragmenter report indicate [you don't have to defrag, just analyse and then Save the rpt for easy reading in notepad]?
Another thing, if XP by itself increments the MFT Zone size [to 25% of total drive space] is it reflected in this key value?
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Filesystem]
"NtfsMftZoneReservation"
If unset, or with a zero value [as set by user either directly in reg or via fsutil] it indicates the MFT Zone is at the standard 12.5% of total drive space.
I don't know about the recurrent attribute error, though.
Just wondering, is all... because my Defrag report figures confuse me as to my MFT size - with 25,700 entries the MFT is 75% in use even though only 33Mb in size. 12.5% of 8GB is 1GB.

Edited by gerbil: n/a

0

Nope.. it's not that.. I find that the MFT Zone does not subtract from available space, cos it IS available space, just reserved unless required by the file system. So.

0

Mmm...this "the MFT is 75% in use even... " could be because of temp file or other large directory deletions following, say, an SP3 upgrade? The MFT grows with the added files, does not shrink as they are deleted, even though the MFT record space is freed, so now files only use 75% of that old total..
I've almost convinced myself. Wonder what free software does an MFT defrag? XP is supposed to be able, but will only if there is enough free space in one block on the drive to copy the MFT metadata files to. MyDefrag?

0

Well,
I have used a program called "Defraggler" and it does a fine job...
Actually my hdd called it quits last saturday after I moved the mouse to take it out of the screensaver. Then it froze. So I rebooted the the disk's platters kept spining up and slowing down and it sounded like the arm was moving back and forth too.So I took it out and I put it into my brother's crappy 450Mhz computer and the event viewer said "The filesyatem on the drive D: is corrupt and unusable please run chkdsk" so I did and it fixed the "mirror copy of the security data stream"---What the heck is that!?!
Anyways, I did get my hdd up and running so it is stable right now but I have a new type of corruption on my drive... corrupt attribute record (160,$IS) or something like that..

Is this a bad hard drive or a bad windows NTFS partition?

P.S:(This is a Dell Optiplex GX270 and the Hard drive is made in 2000 by Western Digital. Model: WD-150EB) I did check the 'SMART' status of the drive and all was good except the spin up time, it was at 111 the lowest value yet (the threshold is 51)
Help!!!

0

Your drive is corrupting its NTFS file system records, the Master File Table.
Security data stream and attribute record are part of the file system metadata, the first codes who can deal how with a file, the second is how it is displayed etc. Pretty much, if the MFT ever becomes irrecoverable ALL your files are irrevocably lost. To all but the most expensive recovery work.
2000. Middle-aged to senior. Get your data off, reformat that partition and see how it performs with new and non-sensitive stuff.

0

Hmm...
O.K. I'll do another back-up soon before I re-format Until then, I'll keep this thread as 'unsolved' in case I need more help!

Thnak-you to everyone who has posted so far!
(It does appear to be unfixable without a format =(...)

0

New problem! I have yet to format but I think I will soon!
I can't use Disk Defragmenter now... Appaerently I don't have sufficent privliges to use it (even though I am my own computer's admin) I checked the security and regisrty and I have full control over it, and I even check its MD5 checksum and it is the same as my brother's....
Has corruption caused this?

P.S Chkdsk says something about free space marked as used in the MFT's bitmap...

0

I have finnally re-installed Windows XP Home and it works fine! I formated the partition as FAT32 instead of NTFS and that seems to help, however once in a while I run chkdsk and it finds some prefetch files are invalid and sometimes the C:\WINDOWS\system32\config\SOFTWARE.LOG file has an invalid size. It tells me to run chkdsk with the /f command (which I do and it tells me to re-schedule for the next reboot but chkdsk finds no problems!) Is my hard drive writing corrupted data? or is this a problem with an part of my computer (i.e RAM?)

If this is a hard drive problem I'll get another hard drive Maybe a 40GB :)

Thanks
javanoob101

0

Get a version of memtest86+ that is the bootable option you would like to run, boot from that medium and run the test for at least half an hour, have a meal and so give it longer... a zero error result would rule out RAM.

0

Well, I ran memtest 86+ for 2 hours and it found no problem with the RAM
This rules out the RAM so this is a hdd problem right? Now, .LOG files and prefetch files always have either an 'invalid size' or 'the first allocation unit is invalid'
This confirmes that I need a new hdd right? *sigh*

Thanks to all for helping out so far!

javanoob101

0

A full format might recover the hard drive. You will have to to a complete reinstall to do that tho!

0

I have already done a full format and I re-installed Windows XP Home with the FAT32 file syatem instead of the NTFS I used before and I am getting 'invalid size' errors or 'the first allocation unit is invalid' when running chkdsk.....

0

ya..I guess I'll have to get a new hard drive soon then :( Oh well...

Thank-you to everyone who posted!!!

javanoob101

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.