0

Before anyone grouses - I searched the forum for similar posts and found none. So if I'm treading on old territory, my apologies...


The situation:

An older gateway tower system running Win XP that operates normally except for multiple ' application will not open because MSVCR71.dll was not found. Try reinstalling the application to fix this problem' errors.' The error dialogs usually appear after windows boot-up while the system is bringing up the desktop icons and system tray. This process literally 'drags' and I assume it is related to the same error!

I've noted the errors are most commonly associated with adobe flash, web mail (Verizon Yahoo) and the HP smart update for the attached HP printer. I've troubleshooted (won't bore you with the detail...), have defragged/ cleaned the registry, DL'd/ installed all the HP drivers from the HP site, reinstalled adobe flash since it had an outdated version anyway.

The most recent problem relates to viewing e-mail and attachments. Some of which will not open due to the same basic error relating to MSVCR71.dll

I do not have the installation CD for this PC and the errors have been ongoing for so long as to make a system restore out of the question. Some have suggested D/L-ing the DLL from third party site but that in my experience is an invitation for disaster.

As you can guess, this is not my PC and I am basically at a standstill with this annoying problem. This should be an easy fix and maybe I'm too close to see the answer. So, I'm asking for a quick and permanent solution.

or in other words... Help!


Thanks everyone!:icon_cool:

Edited by dasd: n/a

4
Contributors
9
Replies
10
Views
6 Years
Discussion Span
Last Post by Sunnyrepairs
0

Have you got SP3 on WinXP?

Either install SP3 again or run scannow /sfc to make sure it correct's any missing system files.

You'll need your XP disc.

You could also try Star Menu > Run > (type in) regsvr32 msvcr71.dll first or if you got access to another XP machine, copy that file from it.

I would run the scannow /sfc anyway to make sure you are not missing any files.

Edited by Bal: n/a

0

msvcr71.dll is a pretty common file, included with a lot of third party softwares. Should be a copy in Pgm Files\Java, for a start. Also Ms .NET.
If you do not wish to trust dll-files.com , then dl Java and copy it over, often to the folder of the software that requires it, but system32 would do.

0

Gerbil and Bal,

I tried one site for a DLL download and the result was not good. Thankfully I had taken precautions prior to this and minimized the threat. Since you have used the 'dll-files' site previously and the site admins have not flagged this post, I'll take that as a good recommendation.:icon_smile: Btw, I did try copying from another app and from a laptop but the effort did not succeed.

I'll have to go back up the mountain in a few days and try this out!

Thanks for the info - it is appreciated.:icon_wink:

0

Okay. I don't know if msvcr71.dll is a library that must be registered.... but if this cmd fails then I guess it does not: Once you have copied msvcr71.dll into system32 then enter in a Run or cmd window...
regsvr32 msvcr71.dll
That might solve your problem with other copies not succeeding.

0

Gerbil,


Thanks again for the assist. I will try that when I can get back to it.

...and btw, why the screen name 'Gerbil'??? Just curious..:icon_smile:

0

dasd

Did you do what I said in my post's?
I've not known the issue to happen after you have applied either of those fixes?
Where did you copy the file and did you do the Run command I said?

Just thinking about the error, when did it first happen?

I have seen similar one's after Verizon software is loaded and you happen to have McAfee Security.

Edited by Bal: n/a

0

The Orange Rat moniker? Ah... not a long story. I was a fan of South Park [still apreciate it], and an episode had just aired where Cartman was telling his mates that he had dreamt a gerbil had crawled up his leg and was eating his xxse; anyway, I needed to complain to a company whose services I used, and to do that I needed to create a login to their chatroom. On the spur of the moment I chose Gerbil [it seemed fitting...], and have stuck with it across other rooms.

Edited by gerbil: n/a

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.