0

I'm running Windows 7 on a Dell Inspiron computer.

Every time I try to open a program (Word, Excel, Photoshop, Ad-Aware, etc) I get a message that says "The program can't start because MSVCR90.dll is missing from your computer. Try reinstalling the program to fix this problem." I've tried to reinstall several programs but before the install can finish the same message appears.

This all started after I had to boot up my computer in "Safe Mode" because it crashed during a System Restore. (During the restore I was prompted to insert my back-up disc. That's when it crashed.)

Any ideas?

4
Contributors
6
Replies
7
Views
6 Years
Discussion Span
Last Post by tkaltenbaugh
0

do this fix first. Run Command Prompt and type in below

chkdsk c: /f /x /r

If fail, do the next fix... In same command prompt

sfc /scannow

Post back here with if it works or fail...

0

Thanks...

When I tried to run chkdsk c:/f/x/r it said, "Access Denied as you do not have sufficient priviliges. You have to invoke this utility running in elevated mode."

When I tried to run sfc/scannow it said, "You must be an administrator running a console session in order to run the sfc utility."

0

for that... I think you have to do it in safe mode or in Windows Recovery Console

Press F8 till the menu for Safe Mode to appear but instead, select 'Repair your computer' if available...

Normally, it would automatically run repair windows startup but if it found nothing, proceed with advance diagnostic or something (I forgot the details) but it should prompt you with 5 programs to use and one of it is Command Prompt. Enter it and type the following above again...

1

instead of using run ,use cmd .go to start and type cmd in the search box ,the cmd will show in the search results ,right click on it and choose run as administrator ,this will give you the upper admin rights you need to run both commands .good luck

Votes + Comments
I forgot it can run in admin... Thanks caperjack...
0

Thanks to all for your support!

After much frustration, I decided to take the "easy" way out. I re-installed Windows 7. This solved the problem.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.