0

When I try to open "My Pictures" I get a "Data Execution Prevention" message and it is Windows Explorer under the program. I tried adding this program under the programs not using DEP but then I just get the message that the program is having a problem and must shut down. I hit debug and got some message about Dr. Watson debugging encountered a problem and must shut down, so I hit debug again and my computer froze. I hit control alt delete and shut My Pictures down. After that when I opened my pictures it just froze.

4
Contributors
12
Replies
13
Views
5 Years
Discussion Span
Last Post by gerbil
0

The probably means that you have a virus on your system. DEP errors generally mean that something is trying to execute data as code, which is one of the ways that a virus uses to pwn your system. One of the things that happens when you open a folder on Windows is that it expands the thumbnail pictures and icons of applications. These are embedded in the files themselves, and as such may contain these types of viruses. Hopefully, you have your important pictures backed up because you will probably need to nuke the folder at the least. In any case, run your AV program (make sure it is up-to-date) and scan your system, preferably after booting into "Safe Mode".

0

The probably means that you have a virus on your system. DEP errors generally mean that something is trying to execute data as code, which is one of the ways that a virus uses to pwn your system. One of the things that happens when you open a folder on Windows is that it expands the thumbnail pictures and icons of applications. These are embedded in the files themselves, and as such may contain these types of viruses. Hopefully, you have your important pictures backed up because you will probably need to nuke the folder at the least. In any case, run your AV program (make sure it is up-to-date) and scan your system, preferably after booting into "Safe Mode".

I ran my av program after rebooting in safe mode and I still have the same problem. When you say nuke the folder do you mean the whole "my pictures" folder or just certain folders in "my pictures"

0

I ran my av program after rebooting in safe mode and I still have the same problem. When you say nuke the folder do you mean the whole "my pictures" folder or just certain folders in "my pictures"

What is your AV program?

Either: (oldschool option)

go back into safe mode, and reopen the folder

enable viewing of hidden files (Tutorial here)

delete:

  • desktop.ini
  • thumbs.db
  • any other hidden files that look like they are not photos

- (hidden files come up looking more pale in colour in explorer)

Or: (the faster option)

download a file manager such as
explorer++

and navigate to the folder using that, then delete the same files as above.

The reasoning:
I am thinking at this point that the problem may be malicious code. If correct, that code is attempting to run itself by embedding itself inside files that explorer would normally open along with the folder. It uses these special hidden files to do things like display special icons for the folder, generate thumbnails of images, and other superflourious information.

the desktop.ini file, if opened should say something like:

[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21779
InfoTip=@%SystemRoot%\system32\shell32.dll,-12688
IconResource=%SystemRoot%\system32\imageres.dll,-113
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-236

in win7. If it says anything different, that is probably your problem.

I cannot give you an idea of thumbs.db, because it is different for every folder.

It is safe to delete these two files. Windows will regenerate them, hopefully back to what they should be. Any others you will need to execute your own judgement upon, or post back your results here.

0

OK. I wsa making sure that it wasn't something obscure and useless. did you try the other suggestions in that post,


Or: (the faster option)

download a file manager such as
explorer++

delete:

desktop.ini
thumbs.db
any other hidden files that look like they are not photos

0

Well I tried the first suggestion, the long way in safe mode with no luck. When I open my pictures I get the window open Windows Explorer " windows exploere has encountered a problem and needs to shutdown. When I double clicked a picture folder it showed thumnail of all the pictures but then another window opened, explorer.exe - application error. the instruction at 0x00000000 referenced memory at 0x00000000. The memory could not be read. I am running Windows XP and the contents of Desktop.ini was nothing like you had posted. This is what it said:
[DeleteOnCopy]]
Owner=HP_Administrator
Personalized=39
PersonalizedName=My Pictures
[.ShellClassInfo]
InfoTip=@shell32.dll,-12688
IconFile=%SystemRoot%\system32\mydocs.dll
IconIndex=-101

0

1. If you are on XP, make sure you have Service Pack 3, plus any other updates for your system.
2. Test your RAM (although usually, RAM problems result in Blue Screen Of Death)
3. gotto start-Run, type
regsvr32 vbscript.dll
press enter.

4. Uninstall Java
Control panel->Add or remove programs

5. Or, drastically, you can modify the registy to enable pool stack overflow correction:

(just ask if you need more help with this)

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management
Value Name: PoolTag
Data Type: REG_DWORD
Data: Pool tag mask | Allocation size mask | 0
(sourced from here for a more complete rundown on this)

OR, and I don't really recommend this, but it is a last-resort type of thing, you could
6. Disable DEP
(read the warnings here)
Then disable it in XP here.

Items are listed in order of severity.
Warning, the "modify the registry" option has the potential to BSOD you. If it does, you need to get into "last good known configuration" - read how to do this before you try the registry changes, here.

0

I show Java update 5,7,29 and J2se runtime enviorment 5.0 update 5 listed in my add/ remove list, do I delete all of them? Nothing happened after I ran the file in suggestion 3

0

Java 6 Update 29 is the latest; you can remove all others.
So is your problem thumbs related? I'll assume that it is.... [because if you have thumbs view selected in explorer then it will open that db file when you select My Pictures; at that time explorer wil also retrieve a list of files and folders in My Pictures from the disk, but not open them].
Try opening explorer in some other folder, go View tab, and select Details. Then try navigating to My Docs > My pictures folder... and delete the thumbs.db file, and also in all subfolders. If again you wish to use the thumbs view in explorer the db will be regenerated.
Did not work? Explorer crashed again? Try using IE instead.. Open Internet Explorer, in the address line type %homepath%
Rclick My Documents icon, choose Open., then rclick My Pictures, choose Open. Delete thumbs.db there and in subfolders.
Did that work?
Explorer generates a thumbs.db in folders from pictures whenever you choose to display thumbnails... I have them disallowed [via Folderr Options, View, Don't cache thumnails] so it never builds those files.
If all that fails, then get Unlocker:
==This is a general purpose force-deleter, Unlocker: http://filehippo.com/download_unlocker/
Dclick the exe to install it, check only the explorer extension box; it then runs from the rclick context menu.
To use in this case, go All Programs and then Start Unlocker; browse to and select the file to delete, press OK. Choose Delete.
Did that work?

Edited by gerbil: n/a

0

I could not find the thumbs.db file to delete. Yesterday I deleted some short videos I had just downloaded from my camera. My problems started after I had put my pictures and videos from my trip. Once I deleted these videos I was able to open My Pictures. When I go to other videos in other files(from my camera) Media player opens but then shuts down quickly. I have never had this problem till this trip. I have put these same pictures and videos on 2 other computers with no issues.

0

thumbs.db files will not show unless you uncheck the Hide protected opsys files option in Explorer, Tools > Folder options > View.
In that same panel you can check the Do not cache thumbnails option - thumbs.db will thereafter not be created/renewed, but old thumbs files will remain - manually delete them from all subfolders.
Somewhere you have a bad file... format is incorrect and Explorer, Media Player break when they load that folder. Both apps build a catalog of contents when you select a folder; Media Player creates a low res preview of each file. Hmm...
You need to find the corrupted files, if that is the problem. Move the suspect files from My Pics to another, new folder. When MP and Explorer work correctly copy back blocks of files until something breaks.
Give VLC a shot.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.