0

When I have my Firefox open I sometimes get this message:
"A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.
Script: chrome://global/content/bindings/browser.xml:0"

The message has two buttons: Stop Script; and Continue"
Does anyone know about this message and how I might disable the script that is trying to execute.?

3
Contributors
2
Replies
3
Views
9 Years
Discussion Span
Last Post by rthomaseidson
0

I've caused that warning a number of times ... as a web developer I write JavaScript--the script--and when I create an endless loop (usually with a while statement, but sometimes with recursive functions) it will continue to execute until the end of time, or until the browser gives you the chance to stop it.

Someone writing the page you're visiting didn't fix their buggy script, so you can either stop it when the browser (FF) prompts you, like you described, or you can disable JavaScript in your browser. To do the latter ...

Tools > Options... > Content (tab) > (deselect) Enable JavaScript (checkbox)

...and enjoy script-free browsing.

Although, doing a quick Google search it seems your particular script might be caused by a poorly written Firefox add-on/plugin ... possibly something called addblock plus. So that might be another direction to search if you keep getting this message.

Hope it helps

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.