0

Hi everyone. I'd like to ak for your help with a messed up partition (probably corrupted table as I understand it). I don't have much experience when it comes to this. Here's my problem: I have a probably corrupted disk and I wanted to create a partition avoiding the bad sectors. I had no idea which app would be suitable so I used a partition magic 8 (it came to my mind first as I used it in the past). I stared it up and it showed some message about fixing my partitions automatically and I was in a hurry so I just clicked ok (silly me, I'll never do that again, it's as our professor used to say - pc administrator should always read every message and warning...). Later when I came home I rebooted and found out that D: is missing. I'm using Windows 7 x64. Disk manager can see the partition but that's it. It shows it as a primary partition but there's no other info as there used to (NTFS, Healthy etc.), just the ammount of space. I booted up ubuntu and was able to backup my files but gparted showed no partitions on my disk at all (weird as I copied files...). I then tried diskpart, it sees the partition but no additional volume that I could assign a letter to.. Oh and when I try to change the letter in disk manager, it shows an error: "Disk Managment console view is not up-to-date." The same error comes up when I try to show partition properties. Tried it in safe mode as well. I don't know what else I can do. I'd appreciate any help :)

1
Contributor
1
Reply
2
Views
5 Years
Discussion Span
Last Post by DarkT
0

Ok, nevermind. I decided to use the longer but easier way :D Since I have the files I'll just format the partition and copy them back... It's 300GB so it'll take a long time but I'm really not in the mood of trying something better... Anyway, feel free to reply. It's better to have the knowledge in case something like this happens again :) I'll mark this as solved...

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.