0

HI guys, I need to format andn reinstall windows 7 on my dell xps 17. Two things though: I don't have any windows installation disk - I suppose there will be a windows 7 iso stored by the manufacter somewhere - and it's dual boot as I have linux installed on another partition. Ideally I would like to format just the windows partition and reinstall it, leaving the linux partition untouched. Is that doable? If so, what are the steps I should take (a search on the net wasn't particularly helpful, so if you guys could point me to a good resource I'd be extremely grateful!)
thanks

7
Contributors
31
Replies
159
Views
2 Years
Discussion Span
Last Post by Violet_82
Featured Replies
  • 1

    You can see Grub's command prompt. Now you need to locate your /boot directory. I think this should show it (throughout I am assuming that partition 4 from your Diskmgmt pic is the Linux partition): ls (hd0,3)/ -you should see vmlinuz initrd.img and boot/ If that doesn't show /boot etc, … Read More

0

Does this dell have a hidden recovery partition that you can use to reinstall Windows?

You should consider wiping the drive clean, re-installing windows and then using a VM application such as virtualBox or vmware to handle guest operating systems so you arent restricted to the dual/multi boot configuration and have to deal with this issue every time you want to reinstall a new OS.

0

No idea if it has a hidden partition, but I'd assume so, because the laptop didn't come with any CD when I bought it. Is there a way to discover this hidden partition and its content?
It kind of crossed my mind to have a VM, but then again, I use both linux and windows (the former on a daily basis, the latter everytime I need to do any dev work, which is more and more often now, so I rather keep both OS. I don't format the HD that often - on this machine this is the first time in 4 yrs, so I don't mind reinstalling everything). So you think it is better to wipe everything rather than trying to keep the linux partition?

0

I have not set up a dual boot machine I believe in about 12 years now so I wouldn't want to steer you in the wrong direction but if it was me that's what I would do. My workstation runs windows as the host OS and I run all my other machines as guest VMs (windows workstations, servers, and Linux) and because they are virtual I can run multiple systems at the same time and I can if I wish allow them to communicate with each other or I can isolate them.

I'm not familiar with that Dell but if you research Dell recovery, you may find the procedure to restore the image. It could be hitting f2 or f10 during the boot up; or f8 then choosing windows repair and on the next menu you would find dells option to restore from image. All vendors do this slightly different.

If you really want to stick with the dual boot, hang around for someone else to provide guidance. I'm not up to date on that procedure any longer.

Edited by JorgeM

0

thanks. To be honest, I've never tried the VM before, so I'm not totally opposed to it. If I do have a VM with multiple OS, will I be able to save files in the guest OS, as in will I be able to operate the guest OS as I can do now with a dual boot? How many OS can I have with a Vm? Is running a VM free or does it involve paying a fee?

Saying that though, the OS's might run a bit slower than if you have a dual boot.

Edited by Violet_82

0

From Windows, run DISKMGMT.MSC. That will show you the disks and partitions. Take a snapshot of the window (ALT-PRTSCR) and post it here. The bottom pane of disk manager will be the most useful so size it so all disks are shown.

0

Hi, sorry I was in a bit of a rush and went ahead, I found the restore utility and reinstalled windows 7 (curiously while I was doing a message informed me that it would have wiped out only the partition where windows was installed). Anyway, here is the screenshot of my disk, after I reinstalled windows http://s15.postimg.org/sjfwy031n/disk.jpg
I don't understand why I have so many partitions:
1)102MB; I guess that's something that windows uses, not bothered with it as it is not a lot
2)Recovery: OK we know what that is
3)OS C: my windows partition;
4)158.32GB: now, could that be the partition where linux is installed? As I said above, when I reinstalled windows it said it formatted only the current partition where windows was installed. If that's linux, how do I boot in it, since it doesn't give me the dual boot option at the startup anymore? Can I boot in linux, or is it "lost"?
5)7.91GB: what is it? ANy idea?
thanks

0

The 102 MB partition is the System Reserved partition. W7 placed it there because at some time you installed W7 to an un-partitioned disk (if you had forced W7 to a prepared partition the SysRes partition would not be built). Don't remove it - booting files are there, and it is needed for Bitlocker.
Your Linux.. it's not marooned. Dual booting W7 and Linux.... get EasyBCD Free. Method is here:
http://askubuntu.com/questions/139966/how-can-i-add-an-entry-for-ubuntu-to-the-windows-7-boot-menu

Edited by gerbil

1

You can see Grub's command prompt. Now you need to locate your /boot directory. I think this should show it (throughout I am assuming that partition 4 from your Diskmgmt pic is the Linux partition):
ls (hd0,3)/
-you should see vmlinuz initrd.img and boot/
If that doesn't show /boot etc, then ls (hd0,tabkey) will list the drive options. Search the likely one with ls.
So then you would run:
root (hd0,3)
kernel /vmlinuz root=/dev/sda4
initrd /initrd.img
boot

Did that boot ubuntu?
(Grub counts from zero, linux from "a" and one)
ls is LS....

Edited by gerbil

Votes + Comments
Its good there are still people like you that seem to understand all of this.. I'll stick with VMs
0

cool will give it a go gerbil, will have to wait till the new year unfortunately as I'm away, so I will leave the thread open and post back as soon as I try

0

eh eh, I'm not far from them, I'm just far from that specific one, got my notebook here, I can't be without a computer.

0

@gerbil, OK so I'm back :-)! I had a go at what you said but I run into some problems when run your commands. Here is a picture of what I got http://s13.postimg.org/ei2s6bafb/IMG_20150106_180212.jpg
I'm not sure why partition 3 is missing...anyway, using the tab key relevaled a 5 partitions as expected but every time I tried to ls in any of them I got the same message:
Filename must be either an absolute pathname or blocklist.
So I run root on the 4th, root (hd0,4) but the system couldn't mount the partition. ANy idea?

0

Get a tool called Super_Grub2(Make a bootable flash of it), using that you should be able to boot in any OS that is installed on your computer.

If the image of the operating system is fine, you will have no problems booting in any of them and once in there you can try to configure your GRUB(I didn't read all the thread so not sure what exactly your problem is but limited with time right now)

If super grub2 can't boot you in, there has to be something wrong with the OS images themselves, in which case I guess you'd have to reinstall your operating systems.

Other thing that you could do is run live Ubuntu and from there run gparted as in sudo gparted and then show us how your HDD partitions from there.

If you got any further questions please do not hesitate to get back here

0

I'd like to try gerbil's solution first, and if that fails I'll attempt something else

0

That missing partition 3 puzzles me. Let's ignore it for the moment.
P0 : 0xde is Dell Utility, so SteveDotNet may well have been right about it, above, after all.
P1,2 : 0x07 are NTFS for W7 (see that your Recovery ptn is set Active, is System? It contains your boot files for W7. Urg.)
P4 : 0x82 is Linux Swap. Pretty huge for a swap partition. Really huge. A dead loss of space.
P5 : 0x83 is Linux, type ext2. So I mixed those last two up in my mind... :)
Anyway...
Note that the command to check a directory terminates with a "/", so:
ls (hd0,4)/ -the "/" makes it a pathname, actually the root directory here.
The tab in ls (hd0, ) just does an auto-complete, or blank query, if you like.
root (hd0,4) might have worked. Or root (hd0,5) ... that missing ptn might or might not need accounting for. But...
ls -will list the partitions.
rootTAB -will find the linux boot ptns. Then root it thus:
root (hd0,?) - get the ? from the root cmd output above. Then:
kernelTAB -will give you the kernel name to use for kernel and initrd cmds.
I could get you to run another software under windows to discover what that missing Ptn 3 is...
That swap ptn.... should be only 2 or 4GB, really. And boot files in the Recovery partition is a bit... untidy. See how we go booting Linux first.

Edited by gerbil

0

I have done this before to old computers all that I do is google up how to factory reset the computer and most of the time you dont need the OS Disk to get the OS back it worked before with my one Windows 7 computer

0

Didn't that make grub your MBR? as in overwrite easyBCD?

The idea I was giving was to use super grub to get into your ubuntu and once there to reinstall the grub from inside

Edited by Slavi

0

no idea mate, I think grub was in the wrong place and it got reinstalled somewhere else, but don't quote me on that as I may be wrong. Fact is, it's fixed.

0

Curious, here. What device is it actually booting on.. dev/sda? I don't think it is sda4....
If you don't mind, it'd be good if you got hold of TestDisk by CGSecurity, and ran it.
Start it > No log > Proceed on disk > Intel > Analyse ... and take a shot of that first screen with the partitions (it's a snap of your MBR).
Post it? (if you go past that screen it is reading partition boundaries from the disk, and that that can show a mishmash cos it picks em all up, even non-overwritten oldies). Not interested in that, yet. Just curious about missing Ptn3.

0

sure could do, but I seem to understand that the missing partition isn't in fact missing, but it has a different label, is there is such a thing. What I mean is, coudn't partition 3 being in fact partition 5 (which is the one I am booting from)?
That testDisk, is it for windows or linux?

0

Oh. Didn't spot your reply. Um... the actual records in your partition structure are simply out of order, which is of no real significance because it is just a list which gets referenced by entry number or searched (eg. for the Active marking), but it plays merry with humans. You can reorder them, but puters don't much mind. TestDisk lists (in that screen) and Windows Disk Mgmnt depicts the partitions as it finds them in the MBR, Lx seems to order them, which is why I thought your Swap was huge (went by the size in Disk Mgmt), and also that boot might be Ptn5. Just as an example, (and one of a perfect structure) I show you a pic of mine:
Boot, then 2 more Primaries, followed by an Extended partition - you can see that the first record of it envelops ALL of the Logical drives. Following Extended partitions envelop each associated Logical drive, which start on the next sector. My partitions all end on cylinder boundaries cos I'm using XP, but W7 partition boundaries are not fixed so. Back to your table...
At the end of your third Primary there is a small gap... no biggie. First Extended (4) points to the following logical partition in the chain (the Swap), while its own (the L Linux) starts on the next sector (again, first E is shown covering the whole of logical drives, but that is not significant, MBR-wise).
So all is good, Lx IS on 4, Swap on 5. You can, for the hell of it, use TD to order your partitions in the MBR, but YOU have to enter the numbers. Not really wise. There is a small utility which does it at the click of a button.

Edited by gerbil

Attachments violet_struct.JPG 98.65 KB
0

I think I can definitely live with that, no problem. There is only one thing.. now I have two boot menus, the first one whish was there before listing about 4-5 entries (I don't have a screenshot with me but it looks pretty similar to this except with different version of OS's and 2 entries for WIndows http://s7.postimg.org/vt1yzjquz/dual_boot_boot_loader.jpg) and if I select windows from here, as I used to do before I get an error, a pretty nasty one saying that ntoskrnl.exe is corrupted http://s16.postimg.org/nhvssoj2d/windows_Error.jpg
But if I instead select the second windows entry I ended up onto another boot screen, this one http://s14.postimg.org/4d4jcboip/enu.jpg and here I can start windows OK. Weird.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.